csmic

CollapseAll image | DropDown image
C#

Visual Basic

Visual C++

CS-MIC - C Sharp Math Input Control
csmic
CS-MIC is a .NET library written in C# designed to give developers easy access to expression parsing. For many developers, there is no need to involve complicated settings and formats. With few exposed methods and objects, CS-MIC makes basic expression solving as simple as possible with as little logic required from developers as possible. In fact, one can pull a value with only one line of code.

Namespaces

Namespace | Description
csmic |
csmic.CodedFunctions |
csmic.Extensions |
csmic.Interpreter |
csmic.Scripting |
Please visit the official site for more information.

Send comments on this topic to Please feel free to provide feedback!

Copyright 2009


csmic Namespace

CS-MIC - C Sharp Math Input Control
csmic Namespace

[Missing <summary> documentation for "N:csmic"]

Types

All Types | Classes | Interfaces | Enumerations
Name | Description
ICodedFunction | Implements a function that is coded in the .Net environment.
InputInterpreter | An interpreter object that reads user input and evaluates the code.
InterpretedFunction | Represents a user defined function that can be executed by the interpreter.
InterpretedFunctionArgument | Represents an argument made in an interpreted function.
MacroBuilder | A builder object that executes macro scripts.
MacroOperation | An operation object that executes a specified action.
OperationType | Represents the operation types supported by a scripted macro.
Variable | An object that contains information about a variable.
VariableType | Represents the data types supported in a variable.


ICodedFunction Interface

| Members | See Also
CS-MIC - C Sharp Math Input Control
ICodedFunction Interface
Implements a function that is coded in the .Net environment.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public interface ICodedFunction
Public Interface ICodedFunction
public interface class ICodedFunction

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Execute(array<Decimal>[]()[][]) | Executes a code block that computes the value of the function.
FunctionName | Gets the name of the function.
NumExpectedArguments | Gets the number of expected arguments.

Remarks

This interface is required to implement a method or function that can be used by the CS-MIC inputInterpreter. It is worth noting that the function's name will be the text that is used in the inputInterpreter as the executable text.

See Also

csmic Namespace


ICodedFunction Methods

| See Also
CS-MIC - C Sharp Math Input Control
ICodedFunction Methods

The ICodedFunction type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Execute(array<Decimal>[]()[][]) | Executes a code block that computes the value of the function.

See Also

ICodedFunction Interface
csmic Namespace


Execute Method

| Example | See Also
CS-MIC - C Sharp Math Input Control
ICodedFunction..::Execute Method
Executes a code block that computes the value of the function.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
decimal Execute(
    params decimal[] args
)
Function Execute ( _
    ParamArray args As Decimal() _
) As Decimal
Decimal Execute(
    ... array<Decimal>^ args
)

Parameters

args
array< Decimal >[]()[][]
An array of arguments passed to the function.

Return Value

The decimal value computed by the function.

Remarks

Any code block is valid. Error handling must be done by the developer, as the inputInterpreter cannot determine if there is an error.

Examples

This example shows how to implement the sine function through the interface's Execute() function.
CopyC#
 public decimal Execute(params decimal[] args)
{
    //Set up an output variable.
    decimal output = 0;

    //Check to see if the number or arguments recieved
    //is equal to the number of arguments expected.
    if (args.Length == this.NumExpectedArguments)
    {
        //Grab the argument and set a local variable for clarity.
        decimal input = args[0];

        //Set the output as a sine of the input.
        output = (decimal)Math.Sin((double)input);
    }

    //Return the output. The function will return the sine if the arguments
    //matched what was expected, and will return 0 otherwise. Returning 0 on
    //errors is the standard in CS-MIC.
    return output;
}

See Also

ICodedFunction Interface
csmic Namespace


ICodedFunction Properties

CS-MIC - C Sharp Math Input Control
ICodedFunction Properties

The ICodedFunction type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
FunctionName | Gets the name of the function.
NumExpectedArguments | Gets the number of expected arguments.

See Also

ICodedFunction Interface
csmic Namespace


FunctionName Property

CS-MIC - C Sharp Math Input Control
ICodedFunction..::FunctionName Property
Gets the name of the function.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
string FunctionName { get; }
ReadOnly Property FunctionName As String
    Get
property String^ FunctionName {
    String^ get ();
}

Remarks

The input inputInterpreter will use this function name as executable text, expecting an opening and closing parenthesis following it.

See Also

ICodedFunction Interface
csmic Namespace


NumExpectedArguments Property

CS-MIC - C Sharp Math Input Control
ICodedFunction..::NumExpectedArguments Property
Gets the number of expected arguments.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
int NumExpectedArguments { get; }
ReadOnly Property NumExpectedArguments As Integer
    Get
property int NumExpectedArguments {
    int get ();
}

See Also

ICodedFunction Interface
csmic Namespace


InputInterpreter Class

| Members | See Also
CS-MIC - C Sharp Math Input Control
InputInterpreter Class
An interpreter object that reads user input and evaluates the code.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public class InputInterpreter
Public Class InputInterpreter
public ref class InputInterpreter

Members

All Members | Constructors | Fields | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
InputInterpreter()()()() | Creates a new InputInterpreter.
InputInterpreter(InputInterpreter) | Creates a new InputInterpreter from an original.
Assign(String, Decimal) | Assigns a decimal value to a variable.
Assign(String, array<Decimal>[]()[][]) | Assigns a decimal value to a variable.
Assign(String, String) | Assigns a decimal value to a variable.
Binary | Gets the value (cast as a long) converted to its binary equivalent.
CodedFunctions | Gets or sets a list of coded functions that the interpreter supports.
ComputeExpression(String) | Computes an expression and returns the result as a decimal.
Decimal | Gets the value of the output as a decimal.
Double | Gets the value of the output cast as a double.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExecuteFunction(String, array<Decimal>[]()[][]) | Executes a function stored in the interpreter.
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Float | Gets the value of the output cast as a float.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Int | Gets the value of the output cast as an int.
Interpret(String) | Interprets and executes given input.
InterpretAsync(String, Action<(Of <<'(InputInterpreter>)>>)) | Interpret an input asynchronously.
InterpretedFunctions | Gets or sets a list of user generated interpreted functions that the interpreter supports.
LastExecutionTime | Gets the execution time of the last calculation.
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Message | Gets the verbose message that is generated with a calculation.
Output | Gets the message that represents the InputInterpreters output.
ProduceOutput(Object) | Produces output given a single object.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
variables | The variables assigned.
Variables | Gets the variables.

Remarks

The interpreter does not support exceptions by design. Instead, invalid calculations, parameters, etc. will result in a result of zero.
CopyC#
InputInterpreter interpreter = new InputInterpreter();
interpreter.Interpret("1/0"); // The result will be 0, not an exception.

Inheritance Hierarchy

System..::..Object
csmic..::..InputInterpreter

See Also

csmic Namespace


InputInterpreter Constructor

CS-MIC - C Sharp Math Input Control
InputInterpreter Constructor

Overload List

Name | Description
InputInterpreter()()()() | Creates a new InputInterpreter.
InputInterpreter(InputInterpreter) | Creates a new InputInterpreter from an original.

See Also

InputInterpreter Class
csmic Namespace


InputInterpreter Constructor

CS-MIC - C Sharp Math Input Control
InputInterpreter Constructor
Creates a new InputInterpreter.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public InputInterpreter()
Public Sub New
public:
InputInterpreter()

See Also

InputInterpreter Class
InputInterpreter Overload
csmic Namespace


InputInterpreter Constructor (InputInterpreter)

CS-MIC - C Sharp Math Input Control
InputInterpreter Constructor (InputInterpreter)
Creates a new InputInterpreter from an original.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public InputInterpreter(
    InputInterpreter original
)
Public Sub New ( _
    original As InputInterpreter _
)
public:
InputInterpreter(
    InputInterpreter^ original
)

Parameters

original
InputInterpreter
The orginal input interpreter to copy.

See Also

InputInterpreter Class
InputInterpreter Overload
csmic Namespace


InputInterpreter Fields

CS-MIC - C Sharp Math Input Control
InputInterpreter Fields

The InputInterpreter type exposes the following fields.

Fields

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
variables | The variables assigned.

See Also

InputInterpreter Class
csmic Namespace


variables Field

CS-MIC - C Sharp Math Input Control
InputInterpreter..::variables Field
The variables assigned.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
internal Dictionary<string, Variable> variables
Friend variables As Dictionary(Of String, Variable)
internal:
Dictionary<String^, Variable^>^ variables

See Also

InputInterpreter Class
csmic Namespace


InputInterpreter Methods

CS-MIC - C Sharp Math Input Control
InputInterpreter Methods

The InputInterpreter type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Assign(String, Decimal) | Assigns a decimal value to a variable.
Assign(String, array<Decimal>[]()[][]) | Assigns a decimal value to a variable.
Assign(String, String) | Assigns a decimal value to a variable.
ComputeExpression(String) | Computes an expression and returns the result as a decimal.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExecuteFunction(String, array<Decimal>[]()[][]) | Executes a function stored in the interpreter.
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Interpret(String) | Interprets and executes given input.
InterpretAsync(String, Action<(Of <<'(InputInterpreter>)>>)) | Interpret an input asynchronously.
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
ProduceOutput(Object) | Produces output given a single object.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InputInterpreter Class
csmic Namespace


Assign Method

CS-MIC - C Sharp Math Input Control
InputInterpreter..::Assign Method

Overload List

Name | Description
Assign(String, Decimal) | Assigns a decimal value to a variable.
Assign(String, array<Decimal>[]()[][]) | Assigns a decimal value to a variable.
Assign(String, String) | Assigns a decimal value to a variable.

See Also

InputInterpreter Class
csmic Namespace


Assign Method (String, Decimal)

CS-MIC - C Sharp Math Input Control
InputInterpreter..::Assign Method (String, Decimal)
Assigns a decimal value to a variable.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
internal bool Assign(
    string name,
    decimal value
)
Friend Function Assign ( _
    name As String, _
    value As Decimal _
) As Boolean
internal:
bool Assign(
    String^ name,
    Decimal value
)

Parameters

name
String
The name of the variable.
value
Decimal
The value of the variable.

Return Value

True if the variable was set, false otherwise.

See Also

InputInterpreter Class
Assign Overload
csmic Namespace


Assign Method (String, Decimal[])

CS-MIC - C Sharp Math Input Control
InputInterpreter..::Assign Method (String, array<Decimal>[]()[][])
Assigns a decimal value to a variable.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
internal bool Assign(
    string name,
    decimal[] values
)
Friend Function Assign ( _
    name As String, _
    values As Decimal() _
) As Boolean
internal:
bool Assign(
    String^ name,
    array<Decimal>^ values
)

Parameters

name
String
The name of the variable.
values
array< Decimal >[]()[][]
The values of the variable.

Return Value

True if the variable was set, false otherwise.

See Also

InputInterpreter Class
Assign Overload
csmic Namespace


Assign Method (String, String)

CS-MIC - C Sharp Math Input Control
InputInterpreter..::Assign Method (String, String)
Assigns a decimal value to a variable.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
internal bool Assign(
    string name,
    string expression
)
Friend Function Assign ( _
    name As String, _
    expression As String _
) As Boolean
internal:
bool Assign(
    String^ name,
    String^ expression
)

Parameters

name
String
The name of the variable.
expression
String
The expression of the variable.

Return Value

True if the variable was set, false otherwise.

See Also

InputInterpreter Class
Assign Overload
csmic Namespace


ComputeExpression Method

CS-MIC - C Sharp Math Input Control
InputInterpreter..::ComputeExpression Method
Computes an expression and returns the result as a decimal.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public decimal ComputeExpression(
    string expression
)
Public Function ComputeExpression ( _
    expression As String _
) As Decimal
public:
Decimal ComputeExpression(
    String^ expression
)

Parameters

expression
String
The expression to be calculated.

Return Value

The value that was computed.

See Also

InputInterpreter Class
csmic Namespace


ExecuteFunction Method

CS-MIC - C Sharp Math Input Control
InputInterpreter..::ExecuteFunction Method
Executes a function stored in the interpreter.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
internal decimal ExecuteFunction(
    string name,
    decimal[] args
)
Friend Function ExecuteFunction ( _
    name As String, _
    args As Decimal() _
) As Decimal
internal:
Decimal ExecuteFunction(
    String^ name,
    array<Decimal>^ args
)

Parameters

name
String
The name of the function to execute.
args
array< Decimal >[]()[][]
The arguments to pass to the function.

Return Value

The value computed from the function execution.

See Also

InputInterpreter Class
csmic Namespace


Interpret Method

CS-MIC - C Sharp Math Input Control
InputInterpreter..::Interpret Method
Interprets and executes given input.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public void Interpret(
    string input
)
Public Sub Interpret ( _
    input As String _
)
public:
void Interpret(
    String^ input
)

Parameters

input
String
The input to interpret and execute.

See Also

InputInterpreter Class
csmic Namespace


InterpretAsync Method

CS-MIC - C Sharp Math Input Control
InputInterpreter..::InterpretAsync Method
Interpret an input asynchronously.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public void InterpretAsync(
    string input,
    Action<InputInterpreter> callback
)
Public Sub InterpretAsync ( _
    input As String, _
    callback As Action(Of InputInterpreter) _
)
public:
void InterpretAsync(
    String^ input,
    Action<InputInterpreter^>^ callback
)

Parameters

input
String
The input to interpret and execute.
callback
Action <(Of <(<' InputInterpreter >)>)>
The callback.

See Also

InputInterpreter Class
csmic Namespace


ProduceOutput Method

CS-MIC - C Sharp Math Input Control
InputInterpreter..::ProduceOutput Method
Produces output given a single object.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
internal void ProduceOutput(
    Object output
)
Friend Sub ProduceOutput ( _
    output As Object _
)
internal:
void ProduceOutput(
    Object^ output
)

Parameters

output
Object
The object representing the output.

See Also

InputInterpreter Class
csmic Namespace


InputInterpreter Properties

CS-MIC - C Sharp Math Input Control
InputInterpreter Properties

The InputInterpreter type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Binary | Gets the value (cast as a long) converted to its binary equivalent.
CodedFunctions | Gets or sets a list of coded functions that the interpreter supports.
Decimal | Gets the value of the output as a decimal.
Double | Gets the value of the output cast as a double.
Float | Gets the value of the output cast as a float.
Int | Gets the value of the output cast as an int.
InterpretedFunctions | Gets or sets a list of user generated interpreted functions that the interpreter supports.
LastExecutionTime | Gets the execution time of the last calculation.
Message | Gets the verbose message that is generated with a calculation.
Output | Gets the message that represents the InputInterpreters output.
Variables | Gets the variables.

See Also

InputInterpreter Class
csmic Namespace


Binary Property

CS-MIC - C Sharp Math Input Control
InputInterpreter..::Binary Property
Gets the value (cast as a long) converted to its binary equivalent.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public string Binary { get; }
Public ReadOnly Property Binary As String
    Get
public:
property String^ Binary {
    String^ get ();
}

See Also

InputInterpreter Class
csmic Namespace


CodedFunctions Property

CS-MIC - C Sharp Math Input Control
InputInterpreter..::CodedFunctions Property
Gets or sets a list of coded functions that the interpreter supports.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public List<ICodedFunction> CodedFunctions { get; set; }
Public Property CodedFunctions As List(Of ICodedFunction)
    Get
    Set
public:
property List<ICodedFunction^>^ CodedFunctions {
    List<ICodedFunction^>^ get ();
    void set (List<ICodedFunction^>^ value);
}

See Also

InputInterpreter Class
csmic Namespace


Decimal Property

CS-MIC - C Sharp Math Input Control
InputInterpreter..::Decimal Property
Gets the value of the output as a decimal.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public decimal Decimal { get; }
Public ReadOnly Property Decimal As Decimal
    Get
public:
property Decimal Decimal {
    Decimal get ();
}

See Also

InputInterpreter Class
csmic Namespace


Double Property

CS-MIC - C Sharp Math Input Control
InputInterpreter..::Double Property
Gets the value of the output cast as a double.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public double Double { get; }
Public ReadOnly Property Double As Double
    Get
public:
property double Double {
    double get ();
}

See Also

InputInterpreter Class
csmic Namespace


Float Property

CS-MIC - C Sharp Math Input Control
InputInterpreter..::Float Property
Gets the value of the output cast as a float.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public float Float { get; }
Public ReadOnly Property Float As Single
    Get
public:
property float Float {
    float get ();
}

See Also

InputInterpreter Class
csmic Namespace


Int Property

CS-MIC - C Sharp Math Input Control
InputInterpreter..::Int Property
Gets the value of the output cast as an int.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public int Int { get; }
Public ReadOnly Property Int As Integer
    Get
public:
property int Int {
    int get ();
}

See Also

InputInterpreter Class
csmic Namespace


InterpretedFunctions Property

CS-MIC - C Sharp Math Input Control
InputInterpreter..::InterpretedFunctions Property
Gets or sets a list of user generated interpreted functions that the interpreter supports.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public List<InterpretedFunction> InterpretedFunctions { get; set; }
Public Property InterpretedFunctions As List(Of InterpretedFunction)
    Get
    Set
public:
property List<InterpretedFunction^>^ InterpretedFunctions {
    List<InterpretedFunction^>^ get ();
    void set (List<InterpretedFunction^>^ value);
}

See Also

InputInterpreter Class
csmic Namespace


LastExecutionTime Property

CS-MIC - C Sharp Math Input Control
InputInterpreter..::LastExecutionTime Property
Gets the execution time of the last calculation.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public TimeSpan LastExecutionTime { get; }
Public ReadOnly Property LastExecutionTime As TimeSpan
    Get
public:
property TimeSpan LastExecutionTime {
    TimeSpan get ();
}

See Also

InputInterpreter Class
csmic Namespace


Message Property

CS-MIC - C Sharp Math Input Control
InputInterpreter..::Message Property
Gets the verbose message that is generated with a calculation.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public string Message { get; }
Public ReadOnly Property Message As String
    Get
public:
property String^ Message {
    String^ get ();
}

See Also

InputInterpreter Class
csmic Namespace


Output Property

CS-MIC - C Sharp Math Input Control
InputInterpreter..::Output Property
Gets the message that represents the InputInterpreters output.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public string Output { get; }
Public ReadOnly Property Output As String
    Get
public:
property String^ Output {
    String^ get ();
}

See Also

InputInterpreter Class
csmic Namespace


Variables Property

CS-MIC - C Sharp Math Input Control
InputInterpreter..::Variables Property
Gets the variables.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public Dictionary<string, Variable> Variables { get; set; }
Public Property Variables As Dictionary(Of String, Variable)
    Get
    Set
public:
property Dictionary<String^, Variable^>^ Variables {
    Dictionary<String^, Variable^>^ get ();
    void set (Dictionary<String^, Variable^>^ value);
}

Field Value

The variables.

See Also

InputInterpreter Class
csmic Namespace


InterpretedFunction Class

| Members | See Also
CS-MIC - C Sharp Math Input Control
InterpretedFunction Class
Represents a user defined function that can be executed by the interpreter.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public class InterpretedFunction
Public Class InterpretedFunction
public ref class InterpretedFunction

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
InterpretedFunction(String, MacroOperation, array<String>[]()[][]) | Creates a new interpreted function.
Compute(array<Decimal>[]()[][]) | Computes the value of the function.
Equals(Object) | Because a function's internal pattern may be different, we must manually check to see if the function names are the same. (Overrides Object..::..Equals(Object).)
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Name | Gets the name of the function.
NumExpectedArguments | Gets the number of expected arguments for the function.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
csmic..::..InterpretedFunction

See Also

csmic Namespace


InterpretedFunction Constructor

CS-MIC - C Sharp Math Input Control
InterpretedFunction Constructor
Creates a new interpreted function.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
internal InterpretedFunction(
    string name,
    MacroOperation script,
    params string[] args
)
Friend Sub New ( _
    name As String, _
    script As MacroOperation, _
    ParamArray args As String() _
)
internal:
InterpretedFunction(
    String^ name,
    MacroOperation^ script,
    ... array<String^>^ args
)

Parameters

name
String
The name of the fuction.
script
MacroOperation
The node to be used in computation.
args
array< String >[]()[][]
A set of argument names to be used in computation.

See Also

InterpretedFunction Class
csmic Namespace


InterpretedFunction Methods

CS-MIC - C Sharp Math Input Control
InterpretedFunction Methods

The InterpretedFunction type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Compute(array<Decimal>[]()[][]) | Computes the value of the function.
Equals(Object) | Because a function's internal pattern may be different, we must manually check to see if the function names are the same. (Overrides Object..::..Equals(Object).)
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Overrides Object..::..GetHashCode()()()().)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InterpretedFunction Class
csmic Namespace


Compute Method

CS-MIC - C Sharp Math Input Control
InterpretedFunction..::Compute Method
Computes the value of the function.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public string Compute(
    params decimal[] args
)
Public Function Compute ( _
    ParamArray args As Decimal() _
) As String
public:
String^ Compute(
    ... array<Decimal>^ args
)

Parameters

args
array< Decimal >[]()[][]
The arguments used for computation.

Return Value

The decimal value computed by the function.

See Also

InterpretedFunction Class
csmic Namespace


Equals Method

CS-MIC - C Sharp Math Input Control
InterpretedFunction..::Equals Method
Because a function's internal pattern may be different, we must manually check to see if the function names are the same.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Object
The object to test.

Return Value

True if the functions are the same.

See Also

InterpretedFunction Class
csmic Namespace


GetHashCode Method

CS-MIC - C Sharp Math Input Control
InterpretedFunction..::GetHashCode Method
Serves as a hash function for a particular type.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override

Return Value

A hash code for the current Object.

See Also

InterpretedFunction Class
csmic Namespace


InterpretedFunction Properties

CS-MIC - C Sharp Math Input Control
InterpretedFunction Properties

The InterpretedFunction type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Name | Gets the name of the function.
NumExpectedArguments | Gets the number of expected arguments for the function.

See Also

InterpretedFunction Class
csmic Namespace


Name Property

CS-MIC - C Sharp Math Input Control
InterpretedFunction..::Name Property
Gets the name of the function.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}

See Also

InterpretedFunction Class
csmic Namespace


NumExpectedArguments Property

CS-MIC - C Sharp Math Input Control
InterpretedFunction..::NumExpectedArguments Property
Gets the number of expected arguments for the function.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public int NumExpectedArguments { get; }
Public ReadOnly Property NumExpectedArguments As Integer
    Get
public:
property int NumExpectedArguments {
    int get ();
}

See Also

InterpretedFunction Class
csmic Namespace


InterpretedFunctionArgument Class

| Members | See Also
CS-MIC - C Sharp Math Input Control
InterpretedFunctionArgument Class
Represents an argument made in an interpreted function.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public class InterpretedFunctionArgument
Public Class InterpretedFunctionArgument
public ref class InterpretedFunctionArgument

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
InterpretedFunctionArgument()()()() | Creates a new interpreted function argument.
InterpretedFunctionArgument(String, Decimal) | Creates a new interpreted function argument.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Name | Gets or sets the name of the argument.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Value | Gets or sets the value of the argument.

Inheritance Hierarchy

System..::..Object
csmic..::..InterpretedFunctionArgument

See Also

csmic Namespace


InterpretedFunctionArgument Constructor

CS-MIC - C Sharp Math Input Control
InterpretedFunctionArgument Constructor

Overload List

Name | Description
InterpretedFunctionArgument()()()() | Creates a new interpreted function argument.
InterpretedFunctionArgument(String, Decimal) | Creates a new interpreted function argument.

See Also

InterpretedFunctionArgument Class
csmic Namespace


InterpretedFunctionArgument Constructor

CS-MIC - C Sharp Math Input Control
InterpretedFunctionArgument Constructor
Creates a new interpreted function argument.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public InterpretedFunctionArgument()
Public Sub New
public:
InterpretedFunctionArgument()

See Also

InterpretedFunctionArgument Class
InterpretedFunctionArgument Overload
csmic Namespace


InterpretedFunctionArgument Constructor (String, Decimal)

CS-MIC - C Sharp Math Input Control
InterpretedFunctionArgument Constructor (String, Decimal)
Creates a new interpreted function argument.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public InterpretedFunctionArgument(
    string name,
    decimal value
)
Public Sub New ( _
    name As String, _
    value As Decimal _
)
public:
InterpretedFunctionArgument(
    String^ name,
    Decimal value
)

Parameters

name
String
The name of the argument in the interpreted function.
value
Decimal
The value of the argument to use in the interpreted function.

See Also

InterpretedFunctionArgument Class
InterpretedFunctionArgument Overload
csmic Namespace


InterpretedFunctionArgument Methods

CS-MIC - C Sharp Math Input Control
InterpretedFunctionArgument Methods

The InterpretedFunctionArgument type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InterpretedFunctionArgument Class
csmic Namespace


InterpretedFunctionArgument Properties

CS-MIC - C Sharp Math Input Control
InterpretedFunctionArgument Properties

The InterpretedFunctionArgument type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Name | Gets or sets the name of the argument.
Value | Gets or sets the value of the argument.

See Also

InterpretedFunctionArgument Class
csmic Namespace


Name Property

CS-MIC - C Sharp Math Input Control
InterpretedFunctionArgument..::Name Property
Gets or sets the name of the argument.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

InterpretedFunctionArgument Class
csmic Namespace


Value Property

CS-MIC - C Sharp Math Input Control
InterpretedFunctionArgument..::Value Property
Gets or sets the value of the argument.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public decimal Value { get; set; }
Public Property Value As Decimal
    Get
    Set
public:
property Decimal Value {
    Decimal get ();
    void set (Decimal value);
}

See Also

InterpretedFunctionArgument Class
csmic Namespace


MacroBuilder Class

| Members | See Also
CS-MIC - C Sharp Math Input Control
MacroBuilder Class
A builder object that executes macro scripts.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public class MacroBuilder
Public Class MacroBuilder
public ref class MacroBuilder

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
MacroBuilder(String, InputInterpreter) | Creates a new builder object that executes a given macro script.
MacroBuilder(MacroOperation, InputInterpreter) | Creates a new builder object that executes a given macro script.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FinalOutput | Gets the decimal value last computed by the macrobuilder.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
LastExecutionTime | Gets the execution time of the last script computation.
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Output | Gets a list of strings representing the output.
Run()()()() | Runs this macro.
RunAsync(String, Action<(Of <<'(MacroBuilder>)>>)) | Executes the asynchronous operation.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
csmic..::..MacroBuilder

See Also

csmic Namespace


MacroBuilder Constructor

CS-MIC - C Sharp Math Input Control
MacroBuilder Constructor

Overload List

Name | Description
MacroBuilder(String, InputInterpreter) | Creates a new builder object that executes a given macro script.
MacroBuilder(MacroOperation, InputInterpreter) | Creates a new builder object that executes a given macro script.

See Also

MacroBuilder Class
csmic Namespace


MacroBuilder Constructor (String, InputInterpreter)

CS-MIC - C Sharp Math Input Control
MacroBuilder Constructor (String, InputInterpreter)
Creates a new builder object that executes a given macro script.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public MacroBuilder(
    string script,
    InputInterpreter inputInterpreter
)
Public Sub New ( _
    script As String, _
    inputInterpreter As InputInterpreter _
)
public:
MacroBuilder(
    String^ script,
    InputInterpreter^ inputInterpreter
)

Parameters

script
String
A list of strings representing the macro.
inputInterpreter
InputInterpreter
The InputInterpreter to be used.

See Also

MacroBuilder Class
MacroBuilder Overload
csmic Namespace


MacroBuilder Constructor (MacroOperation, InputInterpreter)

CS-MIC - C Sharp Math Input Control
MacroBuilder Constructor (MacroOperation, InputInterpreter)
Creates a new builder object that executes a given macro script.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
internal MacroBuilder(
    MacroOperation script,
    InputInterpreter inputInterpreter
)
Friend Sub New ( _
    script As MacroOperation, _
    inputInterpreter As InputInterpreter _
)
internal:
MacroBuilder(
    MacroOperation^ script,
    InputInterpreter^ inputInterpreter
)

Parameters

script
MacroOperation
A list of strings representing the macro.
inputInterpreter
InputInterpreter
The InputInterpreter to be used.

See Also

MacroBuilder Class
MacroBuilder Overload
csmic Namespace


MacroBuilder Methods

CS-MIC - C Sharp Math Input Control
MacroBuilder Methods

The MacroBuilder type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Run()()()() | Runs this macro.
RunAsync(String, Action<(Of <<'(MacroBuilder>)>>)) | Executes the asynchronous operation.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MacroBuilder Class
csmic Namespace


Run Method

CS-MIC - C Sharp Math Input Control
MacroBuilder..::Run Method
Runs this macro.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public void Run()
Public Sub Run
public:
void Run()

See Also

MacroBuilder Class
csmic Namespace


RunAsync Method

CS-MIC - C Sharp Math Input Control
MacroBuilder..::RunAsync Method
Executes the asynchronous operation.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public void RunAsync(
    string input,
    Action<MacroBuilder> callback
)
Public Sub RunAsync ( _
    input As String, _
    callback As Action(Of MacroBuilder) _
)
public:
void RunAsync(
    String^ input,
    Action<MacroBuilder^>^ callback
)

Parameters

input
String
The input.
callback
Action <(Of <(<' MacroBuilder >)>)>
The callback.

See Also

MacroBuilder Class
csmic Namespace


MacroBuilder Properties

CS-MIC - C Sharp Math Input Control
MacroBuilder Properties

The MacroBuilder type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
FinalOutput | Gets the decimal value last computed by the macrobuilder.
LastExecutionTime | Gets the execution time of the last script computation.
Output | Gets a list of strings representing the output.

See Also

MacroBuilder Class
csmic Namespace


FinalOutput Property

CS-MIC - C Sharp Math Input Control
MacroBuilder..::FinalOutput Property
Gets the decimal value last computed by the macrobuilder.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public string FinalOutput { get; }
Public ReadOnly Property FinalOutput As String
    Get
public:
property String^ FinalOutput {
    String^ get ();
}

See Also

MacroBuilder Class
csmic Namespace


LastExecutionTime Property

CS-MIC - C Sharp Math Input Control
MacroBuilder..::LastExecutionTime Property
Gets the execution time of the last script computation.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public TimeSpan LastExecutionTime { get; }
Public ReadOnly Property LastExecutionTime As TimeSpan
    Get
public:
property TimeSpan LastExecutionTime {
    TimeSpan get ();
}

See Also

MacroBuilder Class
csmic Namespace


Output Property

CS-MIC - C Sharp Math Input Control
MacroBuilder..::Output Property
Gets a list of strings representing the output.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public List<string> Output { get; }
Public ReadOnly Property Output As List(Of String)
    Get
public:
property List<String^>^ Output {
    List<String^>^ get ();
}

See Also

MacroBuilder Class
csmic Namespace


MacroOperation Class

| Members | See Also
CS-MIC - C Sharp Math Input Control
MacroOperation Class
An operation object that executes a specified action.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
internal class MacroOperation
Friend Class MacroOperation
internal ref class MacroOperation

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
MacroOperation(OperationType) | Creates a new macro operation node.
Children | Gets or sets the children nodes of the operation.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Input | Gets or sets the input for the operation.
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
OperationType | Gets or sets the operation type for this operation.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
csmic..::..MacroOperation

See Also

csmic Namespace


MacroOperation Constructor

CS-MIC - C Sharp Math Input Control
MacroOperation Constructor
Creates a new macro operation node.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public MacroOperation(
    OperationType operationType
)
Public Sub New ( _
    operationType As OperationType _
)
public:
MacroOperation(
    OperationType operationType
)

Parameters

operationType
OperationType
The type of operation the node represents.

See Also

MacroOperation Class
csmic Namespace


MacroOperation Methods

CS-MIC - C Sharp Math Input Control
MacroOperation Methods

The MacroOperation type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MacroOperation Class
csmic Namespace


MacroOperation Properties

CS-MIC - C Sharp Math Input Control
MacroOperation Properties

The MacroOperation type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Children | Gets or sets the children nodes of the operation.
Input | Gets or sets the input for the operation.
OperationType | Gets or sets the operation type for this operation.

See Also

MacroOperation Class
csmic Namespace


Children Property

CS-MIC - C Sharp Math Input Control
MacroOperation..::Children Property
Gets or sets the children nodes of the operation.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public List<MacroOperation> Children { get; set; }
Public Property Children As List(Of MacroOperation)
    Get
    Set
public:
property List<MacroOperation^>^ Children {
    List<MacroOperation^>^ get ();
    void set (List<MacroOperation^>^ value);
}

See Also

MacroOperation Class
csmic Namespace


Input Property

CS-MIC - C Sharp Math Input Control
MacroOperation..::Input Property
Gets or sets the input for the operation.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public List<string> Input { get; set; }
Public Property Input As List(Of String)
    Get
    Set
public:
property List<String^>^ Input {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

See Also

MacroOperation Class
csmic Namespace


OperationType Property

CS-MIC - C Sharp Math Input Control
MacroOperation..::OperationType Property
Gets or sets the operation type for this operation.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public OperationType OperationType { get; set; }
Public Property OperationType As OperationType
    Get
    Set
public:
property OperationType OperationType {
    OperationType get ();
    void set (OperationType value);
}

See Also

MacroOperation Class
csmic Namespace


OperationType Enumeration

CS-MIC - C Sharp Math Input Control
OperationType Enumeration
Represents the operation types supported by a scripted macro.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
internal enum OperationType
Friend Enumeration OperationType
internal enum class OperationType

Members

Member | Value | Description
If | 0 | Represents a conditional block.
Else | 1 | Represents a conditional else block.
IfElse | 2 | Represents a complete conditional block.
While | 3 | A while block.
For | 4 | A for block.
FunctionDeclaration | 5 | A function declaration.
Echo | 6 | An echo statement.
Say | 7 | A say statement.
Display | 8 | A display statement.
Statement | 9 | A statement to execute.
String | 10 | A string to display.
Unknown | 11 | An unknown or malformed block.

See Also

csmic Namespace


Variable Class

| Members | See Also
CS-MIC - C Sharp Math Input Control
Variable Class
An object that contains information about a variable.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public class Variable
Public Class Variable
public ref class Variable

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Variable()()()() | Creates an empty variable.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Type | Gets or sets the type of the variable.
Value | Gets or sets an object representing the variable's value.

Inheritance Hierarchy

System..::..Object
csmic..::..Variable

See Also

csmic Namespace


Variable Constructor

CS-MIC - C Sharp Math Input Control
Variable Constructor
Creates an empty variable.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public Variable()
Public Sub New
public:
Variable()

See Also

Variable Class
csmic Namespace


Variable Methods

CS-MIC - C Sharp Math Input Control
Variable Methods

The Variable type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Variable Class
csmic Namespace


Variable Properties

CS-MIC - C Sharp Math Input Control
Variable Properties

The Variable type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Type | Gets or sets the type of the variable.
Value | Gets or sets an object representing the variable's value.

See Also

Variable Class
csmic Namespace


Type Property

CS-MIC - C Sharp Math Input Control
Variable..::Type Property
Gets or sets the type of the variable.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public VariableType Type { get; set; }
Public Property Type As VariableType
    Get
    Set
public:
property VariableType Type {
    VariableType get ();
    void set (VariableType value);
}

See Also

Variable Class
csmic Namespace


Value Property

CS-MIC - C Sharp Math Input Control
Variable..::Value Property
Gets or sets an object representing the variable's value.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public Object Value { get; set; }
Public Property Value As Object
    Get
    Set
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}

See Also

Variable Class
csmic Namespace


VariableType Enumeration

CS-MIC - C Sharp Math Input Control
VariableType Enumeration
Represents the data types supported in a variable.

Namespace: csmic
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public enum VariableType
Public Enumeration VariableType
public enum class VariableType

Members

Member | Value | Description
Decimal | 0 | Decimal
Equation | 1 | Equation
Array | 2 | Array
Unknown | 3 | Unknown
None | 4 | No type associated

See Also

csmic Namespace


csmic.CodedFunctions Namespace

CS-MIC - C Sharp Math Input Control
csmic.CodedFunctions Namespace

[Missing <summary> documentation for "N:csmic.CodedFunctions"]

Types

All Types | Classes
Name | Description
CF_Abs | A coded implementation of the absolute value function.
CF_Cos | A coded implementation of the cosine function.
CF_Exp | A coded implementation of the exponential function based on the constant e.
CF_Log | A coded implementation of the log function.
CF_Precision | A coded implementation of a precision function.
CF_Round | A coded implementation of a rounded function.
CF_Sin | A coded implementation of the sine function.
CF_Sqrt | A coded implementation of the squre root function.
CF_Tan | A coded implementation of the tangent function.


CF_Abs Class

| Members | See Also
CS-MIC - C Sharp Math Input Control
CF_Abs Class
A coded implementation of the absolute value function.

Namespace: csmic.CodedFunctions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
internal class CF_Abs : ICodedFunction
Friend Class CF_Abs _
    Implements ICodedFunction
internal ref class CF_Abs : ICodedFunction

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
CF_Abs()()()() | Initializes a new instance of the CF_Abs class
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute(array<Decimal>[]()[][]) | Executes a code block.
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FunctionName | The name of the function.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
NumExpectedArguments | Expects 1 argument.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
csmic.CodedFunctions..::..CF_Abs

See Also

csmic.CodedFunctions Namespace


CF_Abs Constructor

CS-MIC - C Sharp Math Input Control
CF_Abs Constructor
Initializes a new instance of the CF_Abs class

Namespace: csmic.CodedFunctions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public CF_Abs()
Public Sub New
public:
CF_Abs()

See Also

CF_Abs Class
csmic.CodedFunctions Namespace


CF_Abs Methods

CS-MIC - C Sharp Math Input Control
CF_Abs Methods

The CF_Abs type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute(array<Decimal>[]()[][]) | Executes a code block.
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CF_Abs Class
csmic.CodedFunctions Namespace


Execute Method

CS-MIC - C Sharp Math Input Control
CF_Abs..::Execute Method
Executes a code block.

Namespace: csmic.CodedFunctions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public decimal Execute(
    params decimal[] args
)
Public Function Execute ( _
    ParamArray args As Decimal() _
) As Decimal
public:
virtual Decimal Execute(
    ... array<Decimal>^ args
) sealed

Parameters

args
array< Decimal >[]()[][]
The arguments used in the code block.

Return Value

The absolute value of the argument.

Implements

ICodedFunction..::..Execute(array<Decimal>[]()[][])

See Also

CF_Abs Class
csmic.CodedFunctions Namespace


CF_Abs Properties

CS-MIC - C Sharp Math Input Control
CF_Abs Properties

The CF_Abs type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
FunctionName | The name of the function.
NumExpectedArguments | Expects 1 argument.

See Also

CF_Abs Class
csmic.CodedFunctions Namespace


FunctionName Property

CS-MIC - C Sharp Math Input Control
CF_Abs..::FunctionName Property
The name of the function.

Namespace: csmic.CodedFunctions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public string FunctionName { get; }
Public ReadOnly Property FunctionName As String
    Get
public:
virtual property String^ FunctionName {
    String^ get () sealed;
}

Implements

ICodedFunction..::..FunctionName

See Also

CF_Abs Class
csmic.CodedFunctions Namespace


NumExpectedArguments Property

CS-MIC - C Sharp Math Input Control
CF_Abs..::NumExpectedArguments Property
Expects 1 argument.

Namespace: csmic.CodedFunctions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public int NumExpectedArguments { get; }
Public ReadOnly Property NumExpectedArguments As Integer
    Get
public:
virtual property int NumExpectedArguments {
    int get () sealed;
}

Implements

ICodedFunction..::..NumExpectedArguments

See Also

CF_Abs Class
csmic.CodedFunctions Namespace


CF_Cos Class

| Members | See Also
CS-MIC - C Sharp Math Input Control
CF_Cos Class
A coded implementation of the cosine function.

Namespace: csmic.CodedFunctions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
internal class CF_Cos : ICodedFunction
Friend Class CF_Cos _
    Implements ICodedFunction
internal ref class CF_Cos : ICodedFunction

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
CF_Cos()()()() | Initializes a new instance of the CF_Cos class
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute(array<Decimal>[]()[][]) | Executes a code block.
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FunctionName | The name of the function.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
NumExpectedArguments | Expects 1 argument.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
csmic.CodedFunctions..::..CF_Cos

See Also

csmic.CodedFunctions Namespace


CF_Cos Constructor

CS-MIC - C Sharp Math Input Control
CF_Cos Constructor
Initializes a new instance of the CF_Cos class

Namespace: csmic.CodedFunctions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public CF_Cos()
Public Sub New
public:
CF_Cos()

See Also

CF_Cos Class
csmic.CodedFunctions Namespace


CF_Cos Methods

CS-MIC - C Sharp Math Input Control
CF_Cos Methods

The CF_Cos type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute(array<Decimal>[]()[][]) | Executes a code block.
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CF_Cos Class
csmic.CodedFunctions Namespace


Execute Method

CS-MIC - C Sharp Math Input Control
CF_Cos..::Execute Method
Executes a code block.

Namespace: csmic.CodedFunctions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public decimal Execute(
    params decimal[] args
)
Public Function Execute ( _
    ParamArray args As Decimal() _
) As Decimal
public:
virtual Decimal Execute(
    ... array<Decimal>^ args
) sealed

Parameters

args
array< Decimal >[]()[][]
The arguments used in the code block.

Return Value

The cosine of the argument.

Implements

ICodedFunction..::..Execute(array<Decimal>[]()[][])

See Also

CF_Cos Class
csmic.CodedFunctions Namespace


CF_Cos Properties

CS-MIC - C Sharp Math Input Control
CF_Cos Properties

The CF_Cos type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
FunctionName | The name of the function.
NumExpectedArguments | Expects 1 argument.

See Also

CF_Cos Class
csmic.CodedFunctions Namespace


FunctionName Property

CS-MIC - C Sharp Math Input Control
CF_Cos..::FunctionName Property
The name of the function.

Namespace: csmic.CodedFunctions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public string FunctionName { get; }
Public ReadOnly Property FunctionName As String
    Get
public:
virtual property String^ FunctionName {
    String^ get () sealed;
}

Implements

ICodedFunction..::..FunctionName

See Also

CF_Cos Class
csmic.CodedFunctions Namespace


NumExpectedArguments Property

CS-MIC - C Sharp Math Input Control
CF_Cos..::NumExpectedArguments Property
Expects 1 argument.

Namespace: csmic.CodedFunctions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public int NumExpectedArguments { get; }
Public ReadOnly Property NumExpectedArguments As Integer
    Get
public:
virtual property int NumExpectedArguments {
    int get () sealed;
}

Implements

ICodedFunction..::..NumExpectedArguments

See Also

CF_Cos Class
csmic.CodedFunctions Namespace


CF_Exp Class

| Members | See Also
CS-MIC - C Sharp Math Input Control
CF_Exp Class
A coded implementation of the exponential function based on the constant e.

Namespace: csmic.CodedFunctions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
internal class CF_Exp : ICodedFunction
Friend Class CF_Exp _
    Implements ICodedFunction
internal ref class CF_Exp : ICodedFunction

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
CF_Exp()()()() | Initializes a new instance of the CF_Exp class
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute(array<Decimal>[]()[][]) | Executes a code block.
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FunctionName | The name of the function.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
NumExpectedArguments | Expects 1 argument.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
csmic.CodedFunctions..::..CF_Exp

See Also

csmic.CodedFunctions Namespace


CF_Exp Constructor

CS-MIC - C Sharp Math Input Control
CF_Exp Constructor
Initializes a new instance of the CF_Exp class

Namespace: csmic.CodedFunctions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public CF_Exp()
Public Sub New
public:
CF_Exp()

See Also

CF_Exp Class
csmic.CodedFunctions Namespace


CF_Exp Methods

CS-MIC - C Sharp Math Input Control
CF_Exp Methods

The CF_Exp type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute(array<Decimal>[]()[][]) | Executes a code block.
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CF_Exp Class
csmic.CodedFunctions Namespace


Execute Method

CS-MIC - C Sharp Math Input Control
CF_Exp..::Execute Method
Executes a code block.

Namespace: csmic.CodedFunctions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public decimal Execute(
    params decimal[] args
)
Public Function Execute ( _
    ParamArray args As Decimal() _
) As Decimal
public:
virtual Decimal Execute(
    ... array<Decimal>^ args
) sealed

Parameters

args
array< Decimal >[]()[][]
The arguments used in the code block.

Return Value

The constant e raised to the power of the argument.

Implements

ICodedFunction..::..Execute(array<Decimal>[]()[][])

See Also

CF_Exp Class
csmic.CodedFunctions Namespace


CF_Exp Properties

CS-MIC - C Sharp Math Input Control
CF_Exp Properties

The CF_Exp type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
FunctionName | The name of the function.
NumExpectedArguments | Expects 1 argument.

See Also

CF_Exp Class
csmic.CodedFunctions Namespace


FunctionName Property

CS-MIC - C Sharp Math Input Control
CF_Exp..::FunctionName Property
The name of the function.

Namespace: csmic.CodedFunctions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public string FunctionName { get; }
Public ReadOnly Property FunctionName As String
    Get
public:
virtual property String^ FunctionName {
    String^ get () sealed;
}

Implements

ICodedFunction..::..FunctionName

See Also

CF_Exp Class
csmic.CodedFunctions Namespace


NumExpectedArguments Property

CS-MIC - C Sharp Math Input Control
CF_Exp..::NumExpectedArguments Property
Expects 1 argument.

Namespace: csmic.CodedFunctions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public int NumExpectedArguments { get; }
Public ReadOnly Property NumExpectedArguments As Integer
    Get
public:
virtual property int NumExpectedArguments {
    int get () sealed;
}

Implements

ICodedFunction..::..NumExpectedArguments

See Also

CF_Exp Class
csmic.CodedFunctions Namespace


CF_Log Class

| Members | See Also
CS-MIC - C Sharp Math Input Control
CF_Log Class
A coded implementation of the log function.

Namespace: csmic.CodedFunctions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
internal class CF_Log : ICodedFunction
Friend Class CF_Log _
    Implements ICodedFunction
internal ref class CF_Log : ICodedFunction

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
CF_Log()()()() | Initializes a new instance of the CF_Log class
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute(array<Decimal>[]()[][]) | Executes a code block.
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FunctionName | The name of the function.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
NumExpectedArguments | Expects 2 arguments.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
csmic.CodedFunctions..::..CF_Log

See Also

csmic.CodedFunctions Namespace


CF_Log Constructor

CS-MIC - C Sharp Math Input Control
CF_Log Constructor
Initializes a new instance of the CF_Log class

Namespace: csmic.CodedFunctions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public CF_Log()
Public Sub New
public:
CF_Log()

See Also

CF_Log Class
csmic.CodedFunctions Namespace


CF_Log Methods

CS-MIC - C Sharp Math Input Control
CF_Log Methods

The CF_Log type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute(array<Decimal>[]()[][]) | Executes a code block.
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CF_Log Class
csmic.CodedFunctions Namespace


Execute Method

CS-MIC - C Sharp Math Input Control
CF_Log..::Execute Method
Executes a code block.

Namespace: csmic.CodedFunctions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public decimal Execute(
    params decimal[] args
)
Public Function Execute ( _
    ParamArray args As Decimal() _
) As Decimal
public:
virtual Decimal Execute(
    ... array<Decimal>^ args
) sealed

Parameters

args
array< Decimal >[]()[][]
The arguments used in the code block.

Return Value

The log of the first argument to the base of the second argument.

Implements

ICodedFunction..::..Execute(array<Decimal>[]()[][])

See Also

CF_Log Class
csmic.CodedFunctions Namespace


CF_Log Properties

CS-MIC - C Sharp Math Input Control
CF_Log Properties

The CF_Log type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
FunctionName | The name of the function.
NumExpectedArguments | Expects 2 arguments.

See Also

CF_Log Class
csmic.CodedFunctions Namespace


FunctionName Property

CS-MIC - C Sharp Math Input Control
CF_Log..::FunctionName Property
The name of the function.

Namespace: csmic.CodedFunctions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public string FunctionName { get; }
Public ReadOnly Property FunctionName As String
    Get
public:
virtual property String^ FunctionName {
    String^ get () sealed;
}

Implements

ICodedFunction..::..FunctionName

See Also

CF_Log Class
csmic.CodedFunctions Namespace


NumExpectedArguments Property

CS-MIC - C Sharp Math Input Control
CF_Log..::NumExpectedArguments Property
Expects 2 arguments.

Namespace: csmic.CodedFunctions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public int NumExpectedArguments { get; }
Public ReadOnly Property NumExpectedArguments As Integer
    Get
public:
virtual property int NumExpectedArguments {
    int get () sealed;
}

Implements

ICodedFunction..::..NumExpectedArguments

See Also

CF_Log Class
csmic.CodedFunctions Namespace


CF_Precision Class

| Members | See Also
CS-MIC - C Sharp Math Input Control
CF_Precision Class
A coded implementation of a precision function.

Namespace: csmic.CodedFunctions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
internal class CF_Precision : ICodedFunction
Friend Class CF_Precision _
    Implements ICodedFunction
internal ref class CF_Precision : ICodedFunction

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
CF_Precision()()()() | Initializes a new instance of the CF_Precision class
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute(array<Decimal>[]()[][]) | Executes a code block.
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FunctionName | The name of the function.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
NumExpectedArguments | Expects 2 arguments.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
csmic.CodedFunctions..::..CF_Precision

See Also

csmic.CodedFunctions Namespace


CF_Precision Constructor

CS-MIC - C Sharp Math Input Control
CF_Precision Constructor
Initializes a new instance of the CF_Precision class

Namespace: csmic.CodedFunctions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public CF_Precision()
Public Sub New
public:
CF_Precision()

See Also

CF_Precision Class
csmic.CodedFunctions Namespace


CF_Precision Methods

CS-MIC - C Sharp Math Input Control
CF_Precision Methods

The CF_Precision type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute(array<Decimal>[]()[][]) | Executes a code block.
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CF_Precision Class
csmic.CodedFunctions Namespace


Execute Method

CS-MIC - C Sharp Math Input Control
CF_Precision..::Execute Method
Executes a code block.

Namespace: csmic.CodedFunctions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public decimal Execute(
    params decimal[] args
)
Public Function Execute ( _
    ParamArray args As Decimal() _
) As Decimal
public:
virtual Decimal Execute(
    ... array<Decimal>^ args
) sealed

Parameters

args
array< Decimal >[]()[][]
The arguments used in the code block.

Return Value

The first argument to the precision of the argument.

Implements

ICodedFunction..::..Execute(array<Decimal>[]()[][])

See Also

CF_Precision Class
csmic.CodedFunctions Namespace


CF_Precision Properties

CS-MIC - C Sharp Math Input Control
CF_Precision Properties

The CF_Precision type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
FunctionName | The name of the function.
NumExpectedArguments | Expects 2 arguments.

See Also

CF_Precision Class
csmic.CodedFunctions Namespace


FunctionName Property

CS-MIC - C Sharp Math Input Control
CF_Precision..::FunctionName Property
The name of the function.

Namespace: csmic.CodedFunctions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public string FunctionName { get; }
Public ReadOnly Property FunctionName As String
    Get
public:
virtual property String^ FunctionName {
    String^ get () sealed;
}

Implements

ICodedFunction..::..FunctionName

See Also

CF_Precision Class
csmic.CodedFunctions Namespace


NumExpectedArguments Property

CS-MIC - C Sharp Math Input Control
CF_Precision..::NumExpectedArguments Property
Expects 2 arguments.

Namespace: csmic.CodedFunctions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public int NumExpectedArguments { get; }
Public ReadOnly Property NumExpectedArguments As Integer
    Get
public:
virtual property int NumExpectedArguments {
    int get () sealed;
}

Implements

ICodedFunction..::..NumExpectedArguments

See Also

CF_Precision Class
csmic.CodedFunctions Namespace


CF_Round Class

| Members | See Also
CS-MIC - C Sharp Math Input Control
CF_Round Class
A coded implementation of a rounded function.

Namespace: csmic.CodedFunctions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
internal class CF_Round : ICodedFunction
Friend Class CF_Round _
    Implements ICodedFunction
internal ref class CF_Round : ICodedFunction

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
CF_Round()()()() | Initializes a new instance of the CF_Round class
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute(array<Decimal>[]()[][]) | Executes a code block.
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FunctionName | The name of the function.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
NumExpectedArguments | Expects 1 argument.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
csmic.CodedFunctions..::..CF_Round

See Also

csmic.CodedFunctions Namespace


CF_Round Constructor

CS-MIC - C Sharp Math Input Control
CF_Round Constructor
Initializes a new instance of the CF_Round class

Namespace: csmic.CodedFunctions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public CF_Round()
Public Sub New
public:
CF_Round()

See Also

CF_Round Class
csmic.CodedFunctions Namespace


CF_Round Methods

CS-MIC - C Sharp Math Input Control
CF_Round Methods

The CF_Round type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute(array<Decimal>[]()[][]) | Executes a code block.
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CF_Round Class
csmic.CodedFunctions Namespace


Execute Method

CS-MIC - C Sharp Math Input Control
CF_Round..::Execute Method
Executes a code block.

Namespace: csmic.CodedFunctions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public decimal Execute(
    params decimal[] args
)
Public Function Execute ( _
    ParamArray args As Decimal() _
) As Decimal
public:
virtual Decimal Execute(
    ... array<Decimal>^ args
) sealed

Parameters

args
array< Decimal >[]()[][]
The arguments used in the code block.

Return Value

The rounded argument.

Implements

ICodedFunction..::..Execute(array<Decimal>[]()[][])

See Also

CF_Round Class
csmic.CodedFunctions Namespace


CF_Round Properties

CS-MIC - C Sharp Math Input Control
CF_Round Properties

The CF_Round type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
FunctionName | The name of the function.
NumExpectedArguments | Expects 1 argument.

See Also

CF_Round Class
csmic.CodedFunctions Namespace


FunctionName Property

CS-MIC - C Sharp Math Input Control
CF_Round..::FunctionName Property
The name of the function.

Namespace: csmic.CodedFunctions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public string FunctionName { get; }
Public ReadOnly Property FunctionName As String
    Get
public:
virtual property String^ FunctionName {
    String^ get () sealed;
}

Implements

ICodedFunction..::..FunctionName

See Also

CF_Round Class
csmic.CodedFunctions Namespace


NumExpectedArguments Property

CS-MIC - C Sharp Math Input Control
CF_Round..::NumExpectedArguments Property
Expects 1 argument.

Namespace: csmic.CodedFunctions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public int NumExpectedArguments { get; }
Public ReadOnly Property NumExpectedArguments As Integer
    Get
public:
virtual property int NumExpectedArguments {
    int get () sealed;
}

Implements

ICodedFunction..::..NumExpectedArguments

See Also

CF_Round Class
csmic.CodedFunctions Namespace


CF_Sin Class

| Members | See Also
CS-MIC - C Sharp Math Input Control
CF_Sin Class
A coded implementation of the sine function.

Namespace: csmic.CodedFunctions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
internal class CF_Sin : ICodedFunction
Friend Class CF_Sin _
    Implements ICodedFunction
internal ref class CF_Sin : ICodedFunction

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
CF_Sin()()()() | Initializes a new instance of the CF_Sin class
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute(array<Decimal>[]()[][]) | Executes a code block.
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FunctionName | The name of the function.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
NumExpectedArguments | Expects 1 argument.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
csmic.CodedFunctions..::..CF_Sin

See Also

csmic.CodedFunctions Namespace


CF_Sin Constructor

CS-MIC - C Sharp Math Input Control
CF_Sin Constructor
Initializes a new instance of the CF_Sin class

Namespace: csmic.CodedFunctions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public CF_Sin()
Public Sub New
public:
CF_Sin()

See Also

CF_Sin Class
csmic.CodedFunctions Namespace


CF_Sin Methods

CS-MIC - C Sharp Math Input Control
CF_Sin Methods

The CF_Sin type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute(array<Decimal>[]()[][]) | Executes a code block.
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CF_Sin Class
csmic.CodedFunctions Namespace


Execute Method

CS-MIC - C Sharp Math Input Control
CF_Sin..::Execute Method
Executes a code block.

Namespace: csmic.CodedFunctions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public decimal Execute(
    params decimal[] args
)
Public Function Execute ( _
    ParamArray args As Decimal() _
) As Decimal
public:
virtual Decimal Execute(
    ... array<Decimal>^ args
) sealed

Parameters

args
array< Decimal >[]()[][]
The arguments used in the code block.

Return Value

The sine of the argument.

Implements

ICodedFunction..::..Execute(array<Decimal>[]()[][])

See Also

CF_Sin Class
csmic.CodedFunctions Namespace


CF_Sin Properties

CS-MIC - C Sharp Math Input Control
CF_Sin Properties

The CF_Sin type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
FunctionName | The name of the function.
NumExpectedArguments | Expects 1 argument.

See Also

CF_Sin Class
csmic.CodedFunctions Namespace


FunctionName Property

CS-MIC - C Sharp Math Input Control
CF_Sin..::FunctionName Property
The name of the function.

Namespace: csmic.CodedFunctions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public string FunctionName { get; }
Public ReadOnly Property FunctionName As String
    Get
public:
virtual property String^ FunctionName {
    String^ get () sealed;
}

Implements

ICodedFunction..::..FunctionName

See Also

CF_Sin Class
csmic.CodedFunctions Namespace


NumExpectedArguments Property

CS-MIC - C Sharp Math Input Control
CF_Sin..::NumExpectedArguments Property
Expects 1 argument.

Namespace: csmic.CodedFunctions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public int NumExpectedArguments { get; }
Public ReadOnly Property NumExpectedArguments As Integer
    Get
public:
virtual property int NumExpectedArguments {
    int get () sealed;
}

Implements

ICodedFunction..::..NumExpectedArguments

See Also

CF_Sin Class
csmic.CodedFunctions Namespace


CF_Sqrt Class

| Members | See Also
CS-MIC - C Sharp Math Input Control
CF_Sqrt Class
A coded implementation of the squre root function.

Namespace: csmic.CodedFunctions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
internal class CF_Sqrt : ICodedFunction
Friend Class CF_Sqrt _
    Implements ICodedFunction
internal ref class CF_Sqrt : ICodedFunction

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
CF_Sqrt()()()() | Initializes a new instance of the CF_Sqrt class
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute(array<Decimal>[]()[][]) | Executes a code block.
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FunctionName | The name of the function.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
NumExpectedArguments | Expects 1 argument.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
csmic.CodedFunctions..::..CF_Sqrt

See Also

csmic.CodedFunctions Namespace


CF_Sqrt Constructor

CS-MIC - C Sharp Math Input Control
CF_Sqrt Constructor
Initializes a new instance of the CF_Sqrt class

Namespace: csmic.CodedFunctions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public CF_Sqrt()
Public Sub New
public:
CF_Sqrt()

See Also

CF_Sqrt Class
csmic.CodedFunctions Namespace


CF_Sqrt Methods

CS-MIC - C Sharp Math Input Control
CF_Sqrt Methods

The CF_Sqrt type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute(array<Decimal>[]()[][]) | Executes a code block.
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CF_Sqrt Class
csmic.CodedFunctions Namespace


Execute Method

CS-MIC - C Sharp Math Input Control
CF_Sqrt..::Execute Method
Executes a code block.

Namespace: csmic.CodedFunctions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public decimal Execute(
    params decimal[] args
)
Public Function Execute ( _
    ParamArray args As Decimal() _
) As Decimal
public:
virtual Decimal Execute(
    ... array<Decimal>^ args
) sealed

Parameters

args
array< Decimal >[]()[][]
The arguments used in the code block.

Return Value

The square root of the argument.

Implements

ICodedFunction..::..Execute(array<Decimal>[]()[][])

See Also

CF_Sqrt Class
csmic.CodedFunctions Namespace


CF_Sqrt Properties

CS-MIC - C Sharp Math Input Control
CF_Sqrt Properties

The CF_Sqrt type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
FunctionName | The name of the function.
NumExpectedArguments | Expects 1 argument.

See Also

CF_Sqrt Class
csmic.CodedFunctions Namespace


FunctionName Property

CS-MIC - C Sharp Math Input Control
CF_Sqrt..::FunctionName Property
The name of the function.

Namespace: csmic.CodedFunctions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public string FunctionName { get; }
Public ReadOnly Property FunctionName As String
    Get
public:
virtual property String^ FunctionName {
    String^ get () sealed;
}

Implements

ICodedFunction..::..FunctionName

See Also

CF_Sqrt Class
csmic.CodedFunctions Namespace


NumExpectedArguments Property

CS-MIC - C Sharp Math Input Control
CF_Sqrt..::NumExpectedArguments Property
Expects 1 argument.

Namespace: csmic.CodedFunctions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public int NumExpectedArguments { get; }
Public ReadOnly Property NumExpectedArguments As Integer
    Get
public:
virtual property int NumExpectedArguments {
    int get () sealed;
}

Implements

ICodedFunction..::..NumExpectedArguments

See Also

CF_Sqrt Class
csmic.CodedFunctions Namespace


CF_Tan Class

| Members | See Also
CS-MIC - C Sharp Math Input Control
CF_Tan Class
A coded implementation of the tangent function.

Namespace: csmic.CodedFunctions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
internal class CF_Tan : ICodedFunction
Friend Class CF_Tan _
    Implements ICodedFunction
internal ref class CF_Tan : ICodedFunction

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
CF_Tan()()()() | Initializes a new instance of the CF_Tan class
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute(array<Decimal>[]()[][]) | Executes a code block.
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FunctionName | The name of the function.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
NumExpectedArguments | Expects 1 argument.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
csmic.CodedFunctions..::..CF_Tan

See Also

csmic.CodedFunctions Namespace


CF_Tan Constructor

CS-MIC - C Sharp Math Input Control
CF_Tan Constructor
Initializes a new instance of the CF_Tan class

Namespace: csmic.CodedFunctions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public CF_Tan()
Public Sub New
public:
CF_Tan()

See Also

CF_Tan Class
csmic.CodedFunctions Namespace


CF_Tan Methods

CS-MIC - C Sharp Math Input Control
CF_Tan Methods

The CF_Tan type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute(array<Decimal>[]()[][]) | Executes a code block.
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CF_Tan Class
csmic.CodedFunctions Namespace


Execute Method

CS-MIC - C Sharp Math Input Control
CF_Tan..::Execute Method
Executes a code block.

Namespace: csmic.CodedFunctions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public decimal Execute(
    params decimal[] args
)
Public Function Execute ( _
    ParamArray args As Decimal() _
) As Decimal
public:
virtual Decimal Execute(
    ... array<Decimal>^ args
) sealed

Parameters

args
array< Decimal >[]()[][]
The arguments used in the code block.

Return Value

The tangent of the argument.

Implements

ICodedFunction..::..Execute(array<Decimal>[]()[][])

See Also

CF_Tan Class
csmic.CodedFunctions Namespace


CF_Tan Properties

CS-MIC - C Sharp Math Input Control
CF_Tan Properties

The CF_Tan type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
FunctionName | The name of the function.
NumExpectedArguments | Expects 1 argument.

See Also

CF_Tan Class
csmic.CodedFunctions Namespace


FunctionName Property

CS-MIC - C Sharp Math Input Control
CF_Tan..::FunctionName Property
The name of the function.

Namespace: csmic.CodedFunctions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public string FunctionName { get; }
Public ReadOnly Property FunctionName As String
    Get
public:
virtual property String^ FunctionName {
    String^ get () sealed;
}

Implements

ICodedFunction..::..FunctionName

See Also

CF_Tan Class
csmic.CodedFunctions Namespace


NumExpectedArguments Property

CS-MIC - C Sharp Math Input Control
CF_Tan..::NumExpectedArguments Property
Expects 1 argument.

Namespace: csmic.CodedFunctions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public int NumExpectedArguments { get; }
Public ReadOnly Property NumExpectedArguments As Integer
    Get
public:
virtual property int NumExpectedArguments {
    int get () sealed;
}

Implements

ICodedFunction..::..NumExpectedArguments

See Also

CF_Tan Class
csmic.CodedFunctions Namespace


csmic.Extensions Namespace

CS-MIC - C Sharp Math Input Control
csmic.Extensions Namespace

[Missing <summary> documentation for "N:csmic.Extensions"]

Types

All Types | Classes
Name | Description
CSMICExtension | CS-MIC extension methods.


CSMICExtension Class

| Members | See Also
CS-MIC - C Sharp Math Input Control
CSMICExtension Class
CS-MIC extension methods.

Namespace: csmic.Extensions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public static class CSMICExtension
<ExtensionAttribute> _
Public NotInheritable Class CSMICExtension
[ExtensionAttribute]
public ref class CSMICExtension abstract sealed

Members

All Members | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Interpret(IEnumerable<(Of <<'(String>)>>)) | A string extension method that interprets as input the string that calls it.
Interpret(ParallelQuery<(Of <<'(String>)>>)) | A string extension method that interprets as input the strings that calls it in parallel.
Interpret(String) | A string extension method that interprets as input the string that calls it.
Interpret(IEnumerable<(Of <<'(String>)>>), Action<(Of <<'(InputInterpreter>)>>)) | A string extension method that interprets as input the string that calls it.
Interpret<(Of <<'(T>)>>)(IEnumerable<(Of <<'(String>)>>), Func<(Of <<'(InputInterpreter, T>)>>)) | Enumerates input in this collection, returning a selection on the interpreter.
InterpretInParallel(IEnumerable<(Of <<'(String>)>>)) | Enumerates input in parallel in this collection.
InterpretInParallel<(Of <<'(T>)>>)(IEnumerable<(Of <<'(String>)>>), Func<(Of <<'(InputInterpreter, T>)>>)) | Enumerates input in parallel this collection, returning a selection on the interpreter.
RunAsMacro(IEnumerable<(Of <<'(String>)>>)) | A string extension method that executes as macro operation.
RunAsMacro(String) | A string extension method that executes as macro operation.

Inheritance Hierarchy

System..::..Object
csmic.Extensions..::..CSMICExtension

See Also

csmic.Extensions Namespace


CSMICExtension Methods

CS-MIC - C Sharp Math Input Control
CSMICExtension Methods

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Interpret(IEnumerable<(Of <<'(String>)>>)) | A string extension method that interprets as input the string that calls it.
Interpret(ParallelQuery<(Of <<'(String>)>>)) | A string extension method that interprets as input the strings that calls it in parallel.
Interpret(String) | A string extension method that interprets as input the string that calls it.
Interpret(IEnumerable<(Of <<'(String>)>>), Action<(Of <<'(InputInterpreter>)>>)) | A string extension method that interprets as input the string that calls it.
Interpret<(Of <<'(T>)>>)(IEnumerable<(Of <<'(String>)>>), Func<(Of <<'(InputInterpreter, T>)>>)) | Enumerates input in this collection, returning a selection on the interpreter.
InterpretInParallel(IEnumerable<(Of <<'(String>)>>)) | Enumerates input in parallel in this collection.
InterpretInParallel<(Of <<'(T>)>>)(IEnumerable<(Of <<'(String>)>>), Func<(Of <<'(InputInterpreter, T>)>>)) | Enumerates input in parallel this collection, returning a selection on the interpreter.
RunAsMacro(IEnumerable<(Of <<'(String>)>>)) | A string extension method that executes as macro operation.
RunAsMacro(String) | A string extension method that executes as macro operation.

See Also

CSMICExtension Class
csmic.Extensions Namespace


Interpret Method

CS-MIC - C Sharp Math Input Control
CSMICExtension..::Interpret Method

Overload List

Name | Description
Interpret(IEnumerable<(Of <<'(String>)>>)) | A string extension method that interprets as input the string that calls it.
Interpret(ParallelQuery<(Of <<'(String>)>>)) | A string extension method that interprets as input the strings that calls it in parallel.
Interpret(String) | A string extension method that interprets as input the string that calls it.
Interpret(IEnumerable<(Of <<'(String>)>>), Action<(Of <<'(InputInterpreter>)>>)) | A string extension method that interprets as input the string that calls it.
Interpret<(Of <<'(T>)>>)(IEnumerable<(Of <<'(String>)>>), Func<(Of <<'(InputInterpreter, T>)>>)) | Enumerates input in this collection, returning a selection on the interpreter.

See Also

CSMICExtension Class
csmic.Extensions Namespace


Interpret Method (IEnumerable)

CS-MIC - C Sharp Math Input Control
CSMICExtension..::Interpret Method (IEnumerable<(Of <(<'String>)>)>)
A string extension method that interprets as input the string that calls it.

Namespace: csmic.Extensions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public static IEnumerable<string> Interpret(
    this IEnumerable<string> collection
)
<ExtensionAttribute> _
Public Shared Function Interpret ( _
    collection As IEnumerable(Of String) _
) As IEnumerable(Of String)
[ExtensionAttribute]
public:
static IEnumerable<String^>^ Interpret(
    IEnumerable<String^>^ collection
)

Parameters

collection
IEnumerable <(Of <(<' String >)>)>
The collection to act on.

Return Value

The output from the interpretation of the string.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable <(Of <(<' String >)>)>. When you use instance method syntax to call this method, omit the first parameter.

See Also

CSMICExtension Class
Interpret Overload
csmic.Extensions Namespace


Interpret Method (ParallelQuery)

CS-MIC - C Sharp Math Input Control
CSMICExtension..::Interpret Method (ParallelQuery<(Of <(<'String>)>)>)
A string extension method that interprets as input the strings that calls it in parallel.

Namespace: csmic.Extensions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public static IEnumerable<InputInterpreter> Interpret(
    this ParallelQuery<string> collection
)
<ExtensionAttribute> _
Public Shared Function Interpret ( _
    collection As ParallelQuery(Of String) _
) As IEnumerable(Of InputInterpreter)
[ExtensionAttribute]
public:
static IEnumerable<InputInterpreter^>^ Interpret(
    ParallelQuery<String^>^ collection
)

Parameters

collection
ParallelQuery <(Of <(<' String >)>)>
The collection to act on.

Return Value

The output from the interpretation of the string.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ParallelQuery <(Of <(<' String >)>)>. When you use instance method syntax to call this method, omit the first parameter.

See Also

CSMICExtension Class
Interpret Overload
csmic.Extensions Namespace


Interpret Method (String)

CS-MIC - C Sharp Math Input Control
CSMICExtension..::Interpret Method (String)
A string extension method that interprets as input the string that calls it.

Namespace: csmic.Extensions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public static string Interpret(
    this string input
)
<ExtensionAttribute> _
Public Shared Function Interpret ( _
    input As String _
) As String
[ExtensionAttribute]
public:
static String^ Interpret(
    String^ input
)

Parameters

input
String
The input to act on.

Return Value

The output from the interpretation of the string.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter.

See Also

CSMICExtension Class
Interpret Overload
csmic.Extensions Namespace


Interpret Method (IEnumerable, Action)

CS-MIC - C Sharp Math Input Control
CSMICExtension..::Interpret Method (IEnumerable<(Of <(<'String>)>)>, Action<(Of <(<'InputInterpreter>)>)>)
A string extension method that interprets as input the string that calls it.

Namespace: csmic.Extensions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public static IEnumerable<string> Interpret(
    this IEnumerable<string> collection,
    Action<InputInterpreter> action
)
<ExtensionAttribute> _
Public Shared Function Interpret ( _
    collection As IEnumerable(Of String), _
    action As Action(Of InputInterpreter) _
) As IEnumerable(Of String)
[ExtensionAttribute]
public:
static IEnumerable<String^>^ Interpret(
    IEnumerable<String^>^ collection,
    Action<InputInterpreter^>^ action
)

Parameters

collection
IEnumerable <(Of <(<' String >)>)>
The collection to act on.
action
Action <(Of <(<' InputInterpreter >)>)>
The action.

Return Value

The output from the interpretation of the string.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable <(Of <(<' String >)>)>. When you use instance method syntax to call this method, omit the first parameter.

See Also

CSMICExtension Class
Interpret Overload
csmic.Extensions Namespace


Interpret Generic Method

CS-MIC - C Sharp Math Input Control
CSMICExtension..::Interpret<(Of <(<'T>)>)> Method (IEnumerable<(Of <(<'String>)>)>, Func<(Of <(<'InputInterpreter, T>)>)>)
Enumerates input in this collection, returning a selection on the interpreter.

Namespace: csmic.Extensions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public static IEnumerable<T> Interpret<T>(
    this IEnumerable<string> collection,
    Func<InputInterpreter, T> selection
)

<ExtensionAttribute> _
Public Shared Function Interpret(Of T) ( _
    collection As IEnumerable(Of String), _
    selection As Func(Of InputInterpreter, T) _
) As IEnumerable(Of T)
[ExtensionAttribute]
public:
generic<typename T>
static IEnumerable<T>^ Interpret(
    IEnumerable<String^>^ collection,
    Func<InputInterpreter^, T>^ selection
)

Parameters

collection
IEnumerable <(Of <(<' String >)>)>
The collection to act on.
selection
Func <(Of <(<' InputInterpreter, T>)>)>
The selection.

Type Parameters

T
Generic type parameter.

Return Value

An enumerator that allows foreach to be used to process interpret< t> in this collection.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable <(Of <(<' String >)>)>. When you use instance method syntax to call this method, omit the first parameter.

See Also

CSMICExtension Class
Interpret Overload
csmic.Extensions Namespace


InterpretInParallel Method

CS-MIC - C Sharp Math Input Control
CSMICExtension..::InterpretInParallel Method

Overload List

Name | Description
InterpretInParallel(IEnumerable<(Of <<'(String>)>>)) | Enumerates input in parallel in this collection.
InterpretInParallel<(Of <<'(T>)>>)(IEnumerable<(Of <<'(String>)>>), Func<(Of <<'(InputInterpreter, T>)>>)) | Enumerates input in parallel this collection, returning a selection on the interpreter.

See Also

CSMICExtension Class
csmic.Extensions Namespace


InterpretInParallel Method (IEnumerable)

CS-MIC - C Sharp Math Input Control
CSMICExtension..::InterpretInParallel Method (IEnumerable<(Of <(<'String>)>)>)
Enumerates input in parallel in this collection.

Namespace: csmic.Extensions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public static IEnumerable<InputInterpreter> InterpretInParallel(
    this IEnumerable<string> collection
)
<ExtensionAttribute> _
Public Shared Function InterpretInParallel ( _
    collection As IEnumerable(Of String) _
) As IEnumerable(Of InputInterpreter)
[ExtensionAttribute]
public:
static IEnumerable<InputInterpreter^>^ InterpretInParallel(
    IEnumerable<String^>^ collection
)

Parameters

collection
IEnumerable <(Of <(<' String >)>)>
The collection to act on.

Return Value

An enumerator that allows foreach to be used to process interpret in parallel in this collection.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable <(Of <(<' String >)>)>. When you use instance method syntax to call this method, omit the first parameter.

See Also

CSMICExtension Class
InterpretInParallel Overload
csmic.Extensions Namespace


InterpretInParallel Generic Method

CS-MIC - C Sharp Math Input Control
CSMICExtension..::InterpretInParallel<(Of <(<'T>)>)> Method (IEnumerable<(Of <(<'String>)>)>, Func<(Of <(<'InputInterpreter, T>)>)>)
Enumerates input in parallel this collection, returning a selection on the interpreter.

Namespace: csmic.Extensions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public static IEnumerable<T> InterpretInParallel<T>(
    this IEnumerable<string> collection,
    Func<InputInterpreter, T> selection
)

<ExtensionAttribute> _
Public Shared Function InterpretInParallel(Of T) ( _
    collection As IEnumerable(Of String), _
    selection As Func(Of InputInterpreter, T) _
) As IEnumerable(Of T)
[ExtensionAttribute]
public:
generic<typename T>
static IEnumerable<T>^ InterpretInParallel(
    IEnumerable<String^>^ collection,
    Func<InputInterpreter^, T>^ selection
)

Parameters

collection
IEnumerable <(Of <(<' String >)>)>
The collection to act on.
selection
Func <(Of <(<' InputInterpreter, T>)>)>
The selection.

Type Parameters

T
Generic type parameter.

Return Value

An enumerator that allows foreach to be used to process interpret in parallel< t> in this collection.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable <(Of <(<' String >)>)>. When you use instance method syntax to call this method, omit the first parameter.

See Also

CSMICExtension Class
InterpretInParallel Overload
csmic.Extensions Namespace


RunAsMacro Method

CS-MIC - C Sharp Math Input Control
CSMICExtension..::RunAsMacro Method

Overload List

Name | Description
RunAsMacro(IEnumerable<(Of <<'(String>)>>)) | A string extension method that executes as macro operation.
RunAsMacro(String) | A string extension method that executes as macro operation.

See Also

CSMICExtension Class
csmic.Extensions Namespace


RunAsMacro Method (IEnumerable)

CS-MIC - C Sharp Math Input Control
CSMICExtension..::RunAsMacro Method (IEnumerable<(Of <(<'String>)>)>)
A string extension method that executes as macro operation.

Namespace: csmic.Extensions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public static MacroBuilder RunAsMacro(
    this IEnumerable<string> collection
)
<ExtensionAttribute> _
Public Shared Function RunAsMacro ( _
    collection As IEnumerable(Of String) _
) As MacroBuilder
[ExtensionAttribute]
public:
static MacroBuilder^ RunAsMacro(
    IEnumerable<String^>^ collection
)

Parameters

collection
IEnumerable <(Of <(<' String >)>)>
The collection to act on.

Return Value

The final output of the script.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable <(Of <(<' String >)>)>. When you use instance method syntax to call this method, omit the first parameter.

See Also

CSMICExtension Class
RunAsMacro Overload
csmic.Extensions Namespace


RunAsMacro Method (String)

CS-MIC - C Sharp Math Input Control
CSMICExtension..::RunAsMacro Method (String)
A string extension method that executes as macro operation.

Namespace: csmic.Extensions
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public static string RunAsMacro(
    this string script
)
<ExtensionAttribute> _
Public Shared Function RunAsMacro ( _
    script As String _
) As String
[ExtensionAttribute]
public:
static String^ RunAsMacro(
    String^ script
)

Parameters

script
String
The script to act on.

Return Value

The final output of the script.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter.

See Also

CSMICExtension Class
RunAsMacro Overload
csmic.Extensions Namespace


csmic.Interpreter Namespace

CS-MIC - C Sharp Math Input Control
csmic.Interpreter Namespace

[Missing <summary> documentation for "N:csmic.Interpreter"]

Types

All Types | Classes
Name | Description
Buffer |
Errors |
FatalError |
Parser |
Scanner |
Token |
UTF8Buffer |


Buffer Class

| Members | See Also
CS-MIC - C Sharp Math Input Control
Buffer Class

[Missing <summary> documentation for "T:csmic.Interpreter.Buffer"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public class Buffer
Public Class Buffer
public ref class Buffer

Members

All Members | Constructors | Fields | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Buffer(Buffer) | Initializes a new instance of the Buffer class
Buffer(Stream, Boolean) | Initializes a new instance of the Buffer class
Close()()()() |
EOF |
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | (Overrides Object..::..Finalize()()()().)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetString(Int32, Int32) |
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Peek()()()() |
Pos |
Read()()()() |
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
csmic.Interpreter..::..Buffer
csmic.Interpreter..::..UTF8Buffer

See Also

csmic.Interpreter Namespace


Buffer Constructor

CS-MIC - C Sharp Math Input Control
Buffer Constructor

Overload List

Name | Description
Buffer(Buffer) | Initializes a new instance of the Buffer class
Buffer(Stream, Boolean) | Initializes a new instance of the Buffer class

See Also

Buffer Class
csmic.Interpreter Namespace


Buffer Constructor (Buffer)

CS-MIC - C Sharp Math Input Control
Buffer Constructor (Buffer)
Initializes a new instance of the Buffer class

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
protected Buffer(
    Buffer b
)
Protected Sub New ( _
    b As Buffer _
)
protected:
Buffer(
    Buffer^ b
)

Parameters

b
Buffer

[Missing <param name="b"/> documentation for "M:csmic.Interpreter.Buffer.#ctor(csmic.Interpreter.Buffer)"]

See Also

Buffer Class
Buffer Overload
csmic.Interpreter Namespace


Buffer Constructor (Stream, Boolean)

CS-MIC - C Sharp Math Input Control
Buffer Constructor (Stream, Boolean)
Initializes a new instance of the Buffer class

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public Buffer(
    Stream s,
    bool isUserStream
)
Public Sub New ( _
    s As Stream, _
    isUserStream As Boolean _
)
public:
Buffer(
    Stream^ s,
    bool isUserStream
)

Parameters

s
Stream

[Missing <param name="s"/> documentation for "M:csmic.Interpreter.Buffer.#ctor(System.IO.Stream,System.Boolean)"]

isUserStream
Boolean

[Missing <param name="isUserStream"/> documentation for "M:csmic.Interpreter.Buffer.#ctor(System.IO.Stream,System.Boolean)"]

See Also

Buffer Class
Buffer Overload
csmic.Interpreter Namespace


Buffer Fields

CS-MIC - C Sharp Math Input Control
Buffer Fields

The Buffer type exposes the following fields.

Fields

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
EOF |

See Also

Buffer Class
csmic.Interpreter Namespace


EOF Field

CS-MIC - C Sharp Math Input Control
Buffer..::EOF Field

[Missing <summary> documentation for "F:csmic.Interpreter.Buffer.EOF"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public const int EOF
Public Const EOF As Integer
public:
literal int EOF

See Also

Buffer Class
csmic.Interpreter Namespace


Buffer Methods

CS-MIC - C Sharp Math Input Control
Buffer Methods

The Buffer type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Close()()()() |
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | (Overrides Object..::..Finalize()()()().)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetString(Int32, Int32) |
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Peek()()()() |
Read()()()() |
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Buffer Class
csmic.Interpreter Namespace


Close Method

CS-MIC - C Sharp Math Input Control
Buffer..::Close Method

[Missing <summary> documentation for "M:csmic.Interpreter.Buffer.Close"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
protected void Close()
Protected Sub Close
protected:
void Close()

See Also

Buffer Class
csmic.Interpreter Namespace


Finalize Method

CS-MIC - C Sharp Math Input Control
Buffer..::Finalize Method

[Missing <summary> documentation for "M:csmic.Interpreter.Buffer.Finalize"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
protected override void Finalize()
Protected Overrides Sub Finalize
protected:
virtual void Finalize() override

See Also

Buffer Class
csmic.Interpreter Namespace


GetString Method

CS-MIC - C Sharp Math Input Control
Buffer..::GetString Method

[Missing <summary> documentation for "M:csmic.Interpreter.Buffer.GetString(System.Int32,System.Int32)"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public string GetString(
    int beg,
    int end
)
Public Function GetString ( _
    beg As Integer, _
    end As Integer _
) As String
public:
String^ GetString(
    int beg,
    int end
)

Parameters

beg
Int32

[Missing <param name="beg"/> documentation for "M:csmic.Interpreter.Buffer.GetString(System.Int32,System.Int32)"]

end
Int32

[Missing <param name="end"/> documentation for "M:csmic.Interpreter.Buffer.GetString(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:csmic.Interpreter.Buffer.GetString(System.Int32,System.Int32)"]

See Also

Buffer Class
csmic.Interpreter Namespace


Peek Method

CS-MIC - C Sharp Math Input Control
Buffer..::Peek Method

[Missing <summary> documentation for "M:csmic.Interpreter.Buffer.Peek"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public int Peek()
Public Function Peek As Integer
public:
int Peek()

Return Value

[Missing <returns> documentation for "M:csmic.Interpreter.Buffer.Peek"]

See Also

Buffer Class
csmic.Interpreter Namespace


Read Method

CS-MIC - C Sharp Math Input Control
Buffer..::Read Method

[Missing <summary> documentation for "M:csmic.Interpreter.Buffer.Read"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public virtual int Read()
Public Overridable Function Read As Integer
public:
virtual int Read()

Return Value

[Missing <returns> documentation for "M:csmic.Interpreter.Buffer.Read"]

See Also

Buffer Class
csmic.Interpreter Namespace


Buffer Properties

CS-MIC - C Sharp Math Input Control
Buffer Properties

The Buffer type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Pos |

See Also

Buffer Class
csmic.Interpreter Namespace


Pos Property

CS-MIC - C Sharp Math Input Control
Buffer..::Pos Property

[Missing <summary> documentation for "P:csmic.Interpreter.Buffer.Pos"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public int Pos { get; set; }
Public Property Pos As Integer
    Get
    Set
public:
property int Pos {
    int get ();
    void set (int value);
}

See Also

Buffer Class
csmic.Interpreter Namespace


Errors Class

| Members | See Also
CS-MIC - C Sharp Math Input Control
Errors Class

[Missing <summary> documentation for "T:csmic.Interpreter.Errors"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public class Errors
Public Class Errors
public ref class Errors

Members

All Members | Constructors | Fields | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Errors()()()() | Initializes a new instance of the Errors class
builder |
count |
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
errMsgFormat |
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
SemErr(String) |
SemErr(Int32, Int32, String) |
SynErr(Int32, Int32, Int32) |
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Warning(String) |
Warning(Int32, Int32, String) |

Inheritance Hierarchy

System..::..Object
csmic.Interpreter..::..Errors

See Also

csmic.Interpreter Namespace


Errors Constructor

CS-MIC - C Sharp Math Input Control
Errors Constructor
Initializes a new instance of the Errors class

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public Errors()
Public Sub New
public:
Errors()

See Also

Errors Class
csmic.Interpreter Namespace


Errors Fields

CS-MIC - C Sharp Math Input Control
Errors Fields

The Errors type exposes the following fields.

Fields

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
builder |
count |
errMsgFormat |

See Also

Errors Class
csmic.Interpreter Namespace


builder Field

CS-MIC - C Sharp Math Input Control
Errors..::builder Field

[Missing <summary> documentation for "F:csmic.Interpreter.Errors.builder"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public StringBuilder builder
Public builder As StringBuilder
public:
StringBuilder^ builder

See Also

Errors Class
csmic.Interpreter Namespace


count Field

CS-MIC - C Sharp Math Input Control
Errors..::count Field

[Missing <summary> documentation for "F:csmic.Interpreter.Errors.count"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public int count
Public count As Integer
public:
int count

See Also

Errors Class
csmic.Interpreter Namespace


errMsgFormat Field

CS-MIC - C Sharp Math Input Control
Errors..::errMsgFormat Field

[Missing <summary> documentation for "F:csmic.Interpreter.Errors.errMsgFormat"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public string errMsgFormat
Public errMsgFormat As String
public:
String^ errMsgFormat

See Also

Errors Class
csmic.Interpreter Namespace


Errors Methods

CS-MIC - C Sharp Math Input Control
Errors Methods

The Errors type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
SemErr(String) |
SemErr(Int32, Int32, String) |
SynErr(Int32, Int32, Int32) |
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Warning(String) |
Warning(Int32, Int32, String) |

See Also

Errors Class
csmic.Interpreter Namespace


SemErr Method

CS-MIC - C Sharp Math Input Control
Errors..::SemErr Method

Overload List

Name | Description
SemErr(String) |
SemErr(Int32, Int32, String) |

See Also

Errors Class
csmic.Interpreter Namespace


SemErr Method (String)

CS-MIC - C Sharp Math Input Control
Errors..::SemErr Method (String)

[Missing <summary> documentation for "M:csmic.Interpreter.Errors.SemErr(System.String)"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public void SemErr(
    string s
)
Public Sub SemErr ( _
    s As String _
)
public:
void SemErr(
    String^ s
)

Parameters

s
String

[Missing <param name="s"/> documentation for "M:csmic.Interpreter.Errors.SemErr(System.String)"]

See Also

Errors Class
SemErr Overload
csmic.Interpreter Namespace


SemErr Method (Int32, Int32, String)

CS-MIC - C Sharp Math Input Control
Errors..::SemErr Method (Int32, Int32, String)

[Missing <summary> documentation for "M:csmic.Interpreter.Errors.SemErr(System.Int32,System.Int32,System.String)"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public void SemErr(
    int line,
    int col,
    string s
)
Public Sub SemErr ( _
    line As Integer, _
    col As Integer, _
    s As String _
)
public:
void SemErr(
    int line,
    int col,
    String^ s
)

Parameters

line
Int32

[Missing <param name="line"/> documentation for "M:csmic.Interpreter.Errors.SemErr(System.Int32,System.Int32,System.String)"]

col
Int32

[Missing <param name="col"/> documentation for "M:csmic.Interpreter.Errors.SemErr(System.Int32,System.Int32,System.String)"]

s
String

[Missing <param name="s"/> documentation for "M:csmic.Interpreter.Errors.SemErr(System.Int32,System.Int32,System.String)"]

See Also

Errors Class
SemErr Overload
csmic.Interpreter Namespace


SynErr Method

CS-MIC - C Sharp Math Input Control
Errors..::SynErr Method

[Missing <summary> documentation for "M:csmic.Interpreter.Errors.SynErr(System.Int32,System.Int32,System.Int32)"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public void SynErr(
    int line,
    int col,
    int n
)
Public Sub SynErr ( _
    line As Integer, _
    col As Integer, _
    n As Integer _
)
public:
void SynErr(
    int line,
    int col,
    int n
)

Parameters

line
Int32

[Missing <param name="line"/> documentation for "M:csmic.Interpreter.Errors.SynErr(System.Int32,System.Int32,System.Int32)"]

col
Int32

[Missing <param name="col"/> documentation for "M:csmic.Interpreter.Errors.SynErr(System.Int32,System.Int32,System.Int32)"]

n
Int32

[Missing <param name="n"/> documentation for "M:csmic.Interpreter.Errors.SynErr(System.Int32,System.Int32,System.Int32)"]

See Also

Errors Class
csmic.Interpreter Namespace


Warning Method

CS-MIC - C Sharp Math Input Control
Errors..::Warning Method

Overload List

Name | Description
Warning(String) |
Warning(Int32, Int32, String) |

See Also

Errors Class
csmic.Interpreter Namespace


Warning Method (String)

CS-MIC - C Sharp Math Input Control
Errors..::Warning Method (String)

[Missing <summary> documentation for "M:csmic.Interpreter.Errors.Warning(System.String)"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public void Warning(
    string s
)
Public Sub Warning ( _
    s As String _
)
public:
void Warning(
    String^ s
)

Parameters

s
String

[Missing <param name="s"/> documentation for "M:csmic.Interpreter.Errors.Warning(System.String)"]

See Also

Errors Class
Warning Overload
csmic.Interpreter Namespace


Warning Method (Int32, Int32, String)

CS-MIC - C Sharp Math Input Control
Errors..::Warning Method (Int32, Int32, String)

[Missing <summary> documentation for "M:csmic.Interpreter.Errors.Warning(System.Int32,System.Int32,System.String)"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public void Warning(
    int line,
    int col,
    string s
)
Public Sub Warning ( _
    line As Integer, _
    col As Integer, _
    s As String _
)
public:
void Warning(
    int line,
    int col,
    String^ s
)

Parameters

line
Int32

[Missing <param name="line"/> documentation for "M:csmic.Interpreter.Errors.Warning(System.Int32,System.Int32,System.String)"]

col
Int32

[Missing <param name="col"/> documentation for "M:csmic.Interpreter.Errors.Warning(System.Int32,System.Int32,System.String)"]

s
String

[Missing <param name="s"/> documentation for "M:csmic.Interpreter.Errors.Warning(System.Int32,System.Int32,System.String)"]

See Also

Errors Class
Warning Overload
csmic.Interpreter Namespace


FatalError Class

| Members | See Also
CS-MIC - C Sharp Math Input Control
FatalError Class

[Missing <summary> documentation for "T:csmic.Interpreter.FatalError"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public class FatalError : Exception
Public Class FatalError _
    Inherits Exception
public ref class FatalError : public Exception

Members

All Members | Constructors | Properties | Methods | Events
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
FatalError(String) | Initializes a new instance of the FatalError class
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException()()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType()()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
ToString()()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Inheritance Hierarchy

System..::..Object
System..::..Exception
csmic.Interpreter..::..FatalError

See Also

csmic.Interpreter Namespace


FatalError Constructor

CS-MIC - C Sharp Math Input Control
FatalError Constructor
Initializes a new instance of the FatalError class

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public FatalError(
    string m
)
Public Sub New ( _
    m As String _
)
public:
FatalError(
    String^ m
)

Parameters

m
String

[Missing <param name="m"/> documentation for "M:csmic.Interpreter.FatalError.#ctor(System.String)"]

See Also

FatalError Class
csmic.Interpreter Namespace


FatalError Methods

CS-MIC - C Sharp Math Input Control
FatalError Methods

The FatalError type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException()()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType()()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString()()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

FatalError Class
csmic.Interpreter Namespace


FatalError Properties

CS-MIC - C Sharp Math Input Control
FatalError Properties

The FatalError type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FatalError Class
csmic.Interpreter Namespace


FatalError Events

CS-MIC - C Sharp Math Input Control
FatalError Events

The FatalError type exposes the following events.

Events

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

FatalError Class
csmic.Interpreter Namespace


Parser Class

| Members | See Also
CS-MIC - C Sharp Math Input Control
Parser Class

[Missing <summary> documentation for "T:csmic.Interpreter.Parser"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public class Parser
Public Class Parser
public ref class Parser

Members

All Members | Constructors | Fields | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Parser(Scanner) | Initializes a new instance of the Parser class
_binary |
_COMPARER |
_EOF |
_hex |
_identifier |
_LPAREN |
_number |
_RPAREN |
_sign |
CalculatedValue |
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
errors |
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Interpreter |
la |
maxT |
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Parse()()()() |
scanner |
SemErr(String) |
t |
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
csmic.Interpreter..::..Parser

See Also

csmic.Interpreter Namespace


Parser Constructor

CS-MIC - C Sharp Math Input Control
Parser Constructor
Initializes a new instance of the Parser class

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public Parser(
    Scanner scanner
)
Public Sub New ( _
    scanner As Scanner _
)
public:
Parser(
    Scanner^ scanner
)

Parameters

scanner
Scanner

[Missing <param name="scanner"/> documentation for "M:csmic.Interpreter.Parser.#ctor(csmic.Interpreter.Scanner)"]

See Also

Parser Class
csmic.Interpreter Namespace


Parser Fields

CS-MIC - C Sharp Math Input Control
Parser Fields

The Parser type exposes the following fields.

Fields

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
_binary |
_COMPARER |
_EOF |
_hex |
_identifier |
_LPAREN |
_number |
_RPAREN |
_sign |
errors |
la |
maxT |
scanner |
t |

See Also

Parser Class
csmic.Interpreter Namespace


_binary Field

CS-MIC - C Sharp Math Input Control
Parser..::_binary Field

[Missing <summary> documentation for "F:csmic.Interpreter.Parser._binary"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public const int _binary
Public Const _binary As Integer
public:
literal int _binary

See Also

Parser Class
csmic.Interpreter Namespace


_COMPARER Field

CS-MIC - C Sharp Math Input Control
Parser..::_COMPARER Field

[Missing <summary> documentation for "F:csmic.Interpreter.Parser._COMPARER"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public const int _COMPARER
Public Const _COMPARER As Integer
public:
literal int _COMPARER

See Also

Parser Class
csmic.Interpreter Namespace


_EOF Field

CS-MIC - C Sharp Math Input Control
Parser..::_EOF Field

[Missing <summary> documentation for "F:csmic.Interpreter.Parser._EOF"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public const int _EOF
Public Const _EOF As Integer
public:
literal int _EOF

See Also

Parser Class
csmic.Interpreter Namespace


_hex Field

CS-MIC - C Sharp Math Input Control
Parser..::_hex Field

[Missing <summary> documentation for "F:csmic.Interpreter.Parser._hex"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public const int _hex
Public Const _hex As Integer
public:
literal int _hex

See Also

Parser Class
csmic.Interpreter Namespace


_identifier Field

CS-MIC - C Sharp Math Input Control
Parser..::_identifier Field

[Missing <summary> documentation for "F:csmic.Interpreter.Parser._identifier"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public const int _identifier
Public Const _identifier As Integer
public:
literal int _identifier

See Also

Parser Class
csmic.Interpreter Namespace


_LPAREN Field

CS-MIC - C Sharp Math Input Control
Parser..::_LPAREN Field

[Missing <summary> documentation for "F:csmic.Interpreter.Parser._LPAREN"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public const int _LPAREN
Public Const _LPAREN As Integer
public:
literal int _LPAREN

See Also

Parser Class
csmic.Interpreter Namespace


_number Field

CS-MIC - C Sharp Math Input Control
Parser..::_number Field

[Missing <summary> documentation for "F:csmic.Interpreter.Parser._number"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public const int _number
Public Const _number As Integer
public:
literal int _number

See Also

Parser Class
csmic.Interpreter Namespace


_RPAREN Field

CS-MIC - C Sharp Math Input Control
Parser..::_RPAREN Field

[Missing <summary> documentation for "F:csmic.Interpreter.Parser._RPAREN"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public const int _RPAREN
Public Const _RPAREN As Integer
public:
literal int _RPAREN

See Also

Parser Class
csmic.Interpreter Namespace


_sign Field

CS-MIC - C Sharp Math Input Control
Parser..::_sign Field

[Missing <summary> documentation for "F:csmic.Interpreter.Parser._sign"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public const int _sign
Public Const _sign As Integer
public:
literal int _sign

See Also

Parser Class
csmic.Interpreter Namespace


errors Field

CS-MIC - C Sharp Math Input Control
Parser..::errors Field

[Missing <summary> documentation for "F:csmic.Interpreter.Parser.errors"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public Errors errors
Public errors As Errors
public:
Errors^ errors

See Also

Parser Class
csmic.Interpreter Namespace


la Field

CS-MIC - C Sharp Math Input Control
Parser..::la Field

[Missing <summary> documentation for "F:csmic.Interpreter.Parser.la"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public Token la
Public la As Token
public:
Token^ la

See Also

Parser Class
csmic.Interpreter Namespace


maxT Field

CS-MIC - C Sharp Math Input Control
Parser..::maxT Field

[Missing <summary> documentation for "F:csmic.Interpreter.Parser.maxT"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public const int maxT
Public Const maxT As Integer
public:
literal int maxT

See Also

Parser Class
csmic.Interpreter Namespace


scanner Field

CS-MIC - C Sharp Math Input Control
Parser..::scanner Field

[Missing <summary> documentation for "F:csmic.Interpreter.Parser.scanner"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public Scanner scanner
Public scanner As Scanner
public:
Scanner^ scanner

See Also

Parser Class
csmic.Interpreter Namespace


t Field

CS-MIC - C Sharp Math Input Control
Parser..::t Field

[Missing <summary> documentation for "F:csmic.Interpreter.Parser.t"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public Token t
Public t As Token
public:
Token^ t

See Also

Parser Class
csmic.Interpreter Namespace


Parser Methods

CS-MIC - C Sharp Math Input Control
Parser Methods

The Parser type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Parse()()()() |
SemErr(String) |
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Parser Class
csmic.Interpreter Namespace


Parse Method

CS-MIC - C Sharp Math Input Control
Parser..::Parse Method

[Missing <summary> documentation for "M:csmic.Interpreter.Parser.Parse"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public void Parse()
Public Sub Parse
public:
void Parse()

See Also

Parser Class
csmic.Interpreter Namespace


SemErr Method

CS-MIC - C Sharp Math Input Control
Parser..::SemErr Method

[Missing <summary> documentation for "M:csmic.Interpreter.Parser.SemErr(System.String)"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public void SemErr(
    string msg
)
Public Sub SemErr ( _
    msg As String _
)
public:
void SemErr(
    String^ msg
)

Parameters

msg
String

[Missing <param name="msg"/> documentation for "M:csmic.Interpreter.Parser.SemErr(System.String)"]

See Also

Parser Class
csmic.Interpreter Namespace


Parser Properties

CS-MIC - C Sharp Math Input Control
Parser Properties

The Parser type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
CalculatedValue |
Interpreter |

See Also

Parser Class
csmic.Interpreter Namespace


CalculatedValue Property

CS-MIC - C Sharp Math Input Control
Parser..::CalculatedValue Property

[Missing <summary> documentation for "P:csmic.Interpreter.Parser.CalculatedValue"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public decimal CalculatedValue { get; set; }
Public Property CalculatedValue As Decimal
    Get
    Set
public:
property Decimal CalculatedValue {
    Decimal get ();
    void set (Decimal value);
}

See Also

Parser Class
csmic.Interpreter Namespace


Interpreter Property

CS-MIC - C Sharp Math Input Control
Parser..::Interpreter Property

[Missing <summary> documentation for "P:csmic.Interpreter.Parser.Interpreter"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public InputInterpreter Interpreter { get; set; }
Public Property Interpreter As InputInterpreter
    Get
    Set
public:
property InputInterpreter^ Interpreter {
    InputInterpreter^ get ();
    void set (InputInterpreter^ value);
}

See Also

Parser Class
csmic.Interpreter Namespace


Scanner Class

| Members | See Also
CS-MIC - C Sharp Math Input Control
Scanner Class

[Missing <summary> documentation for "T:csmic.Interpreter.Scanner"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public class Scanner
Public Class Scanner
public ref class Scanner

Members

All Members | Constructors | Fields | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Scanner(Stream) | Initializes a new instance of the Scanner class
Scanner(String) | Initializes a new instance of the Scanner class
buffer |
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Peek()()()() |
ResetPeek()()()() |
Scan()()()() |
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
csmic.Interpreter..::..Scanner

See Also

csmic.Interpreter Namespace


Scanner Constructor

CS-MIC - C Sharp Math Input Control
Scanner Constructor

Overload List

Name | Description
Scanner(Stream) | Initializes a new instance of the Scanner class
Scanner(String) | Initializes a new instance of the Scanner class

See Also

Scanner Class
csmic.Interpreter Namespace


Scanner Constructor (Stream)

CS-MIC - C Sharp Math Input Control
Scanner Constructor (Stream)
Initializes a new instance of the Scanner class

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public Scanner(
    Stream s
)
Public Sub New ( _
    s As Stream _
)
public:
Scanner(
    Stream^ s
)

Parameters

s
Stream

[Missing <param name="s"/> documentation for "M:csmic.Interpreter.Scanner.#ctor(System.IO.Stream)"]

See Also

Scanner Class
Scanner Overload
csmic.Interpreter Namespace


Scanner Constructor (String)

CS-MIC - C Sharp Math Input Control
Scanner Constructor (String)
Initializes a new instance of the Scanner class

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public Scanner(
    string fileName
)
Public Sub New ( _
    fileName As String _
)
public:
Scanner(
    String^ fileName
)

Parameters

fileName
String

[Missing <param name="fileName"/> documentation for "M:csmic.Interpreter.Scanner.#ctor(System.String)"]

See Also

Scanner Class
Scanner Overload
csmic.Interpreter Namespace


Scanner Fields

CS-MIC - C Sharp Math Input Control
Scanner Fields

The Scanner type exposes the following fields.

Fields

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
buffer |

See Also

Scanner Class
csmic.Interpreter Namespace


buffer Field

CS-MIC - C Sharp Math Input Control
Scanner..::buffer Field

[Missing <summary> documentation for "F:csmic.Interpreter.Scanner.buffer"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public Buffer buffer
Public buffer As Buffer
public:
Buffer^ buffer

See Also

Scanner Class
csmic.Interpreter Namespace


Scanner Methods

CS-MIC - C Sharp Math Input Control
Scanner Methods

The Scanner type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Peek()()()() |
ResetPeek()()()() |
Scan()()()() |
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Scanner Class
csmic.Interpreter Namespace


Peek Method

CS-MIC - C Sharp Math Input Control
Scanner..::Peek Method

[Missing <summary> documentation for "M:csmic.Interpreter.Scanner.Peek"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public Token Peek()
Public Function Peek As Token
public:
Token^ Peek()

Return Value

[Missing <returns> documentation for "M:csmic.Interpreter.Scanner.Peek"]

See Also

Scanner Class
csmic.Interpreter Namespace


ResetPeek Method

CS-MIC - C Sharp Math Input Control
Scanner..::ResetPeek Method

[Missing <summary> documentation for "M:csmic.Interpreter.Scanner.ResetPeek"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public void ResetPeek()
Public Sub ResetPeek
public:
void ResetPeek()

See Also

Scanner Class
csmic.Interpreter Namespace


Scan Method

CS-MIC - C Sharp Math Input Control
Scanner..::Scan Method

[Missing <summary> documentation for "M:csmic.Interpreter.Scanner.Scan"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public Token Scan()
Public Function Scan As Token
public:
Token^ Scan()

Return Value

[Missing <returns> documentation for "M:csmic.Interpreter.Scanner.Scan"]

See Also

Scanner Class
csmic.Interpreter Namespace


Token Class

| Members | See Also
CS-MIC - C Sharp Math Input Control
Token Class

[Missing <summary> documentation for "T:csmic.Interpreter.Token"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public class Token
Public Class Token
public ref class Token

Members

All Members | Constructors | Fields | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Token()()()() | Initializes a new instance of the Token class
charPos |
col |
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
kind |
line |
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
next |
pos |
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
val |

Inheritance Hierarchy

System..::..Object
csmic.Interpreter..::..Token

See Also

csmic.Interpreter Namespace


Token Constructor

CS-MIC - C Sharp Math Input Control
Token Constructor
Initializes a new instance of the Token class

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public Token()
Public Sub New
public:
Token()

See Also

Token Class
csmic.Interpreter Namespace


Token Fields

CS-MIC - C Sharp Math Input Control
Token Fields

The Token type exposes the following fields.

Fields

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
charPos |
col |
kind |
line |
next |
pos |
val |

See Also

Token Class
csmic.Interpreter Namespace


charPos Field

CS-MIC - C Sharp Math Input Control
Token..::charPos Field

[Missing <summary> documentation for "F:csmic.Interpreter.Token.charPos"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public int charPos
Public charPos As Integer
public:
int charPos

See Also

Token Class
csmic.Interpreter Namespace


col Field

CS-MIC - C Sharp Math Input Control
Token..::col Field

[Missing <summary> documentation for "F:csmic.Interpreter.Token.col"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public int col
Public col As Integer
public:
int col

See Also

Token Class
csmic.Interpreter Namespace


kind Field

CS-MIC - C Sharp Math Input Control
Token..::kind Field

[Missing <summary> documentation for "F:csmic.Interpreter.Token.kind"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public int kind
Public kind As Integer
public:
int kind

See Also

Token Class
csmic.Interpreter Namespace


line Field

CS-MIC - C Sharp Math Input Control
Token..::line Field

[Missing <summary> documentation for "F:csmic.Interpreter.Token.line"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public int line
Public line As Integer
public:
int line

See Also

Token Class
csmic.Interpreter Namespace


next Field

CS-MIC - C Sharp Math Input Control
Token..::next Field

[Missing <summary> documentation for "F:csmic.Interpreter.Token.next"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public Token next
Public next As Token
public:
Token^ next

See Also

Token Class
csmic.Interpreter Namespace


pos Field

CS-MIC - C Sharp Math Input Control
Token..::pos Field

[Missing <summary> documentation for "F:csmic.Interpreter.Token.pos"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public int pos
Public pos As Integer
public:
int pos

See Also

Token Class
csmic.Interpreter Namespace


val Field

CS-MIC - C Sharp Math Input Control
Token..::val Field

[Missing <summary> documentation for "F:csmic.Interpreter.Token.val"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public string val
Public val As String
public:
String^ val

See Also

Token Class
csmic.Interpreter Namespace


Token Methods

CS-MIC - C Sharp Math Input Control
Token Methods

The Token type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Token Class
csmic.Interpreter Namespace


UTF8Buffer Class

| Members | See Also
CS-MIC - C Sharp Math Input Control
UTF8Buffer Class

[Missing <summary> documentation for "T:csmic.Interpreter.UTF8Buffer"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public class UTF8Buffer : Buffer
Public Class UTF8Buffer _
    Inherits Buffer
public ref class UTF8Buffer : public Buffer

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
UTF8Buffer(Buffer) | Initializes a new instance of the UTF8Buffer class
Close()()()() | (Inherited from Buffer.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | (Inherited from Buffer.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetString(Int32, Int32) | (Inherited from Buffer.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Peek()()()() | (Inherited from Buffer.)
Pos | (Inherited from Buffer.)
Read()()()() | (Overrides Buffer..::..Read()()()().)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
csmic.Interpreter..::..Buffer
csmic.Interpreter..::..UTF8Buffer

See Also

csmic.Interpreter Namespace


UTF8Buffer Constructor

CS-MIC - C Sharp Math Input Control
UTF8Buffer Constructor
Initializes a new instance of the UTF8Buffer class

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public UTF8Buffer(
    Buffer b
)
Public Sub New ( _
    b As Buffer _
)
public:
UTF8Buffer(
    Buffer^ b
)

Parameters

b
Buffer

[Missing <param name="b"/> documentation for "M:csmic.Interpreter.UTF8Buffer.#ctor(csmic.Interpreter.Buffer)"]

See Also

UTF8Buffer Class
csmic.Interpreter Namespace


UTF8Buffer Methods

CS-MIC - C Sharp Math Input Control
UTF8Buffer Methods

The UTF8Buffer type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Close()()()() | (Inherited from Buffer.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | (Inherited from Buffer.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetString(Int32, Int32) | (Inherited from Buffer.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Peek()()()() | (Inherited from Buffer.)
Read()()()() | (Overrides Buffer..::..Read()()()().)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UTF8Buffer Class
csmic.Interpreter Namespace


Read Method

CS-MIC - C Sharp Math Input Control
UTF8Buffer..::Read Method

[Missing <summary> documentation for "M:csmic.Interpreter.UTF8Buffer.Read"]

Namespace: csmic.Interpreter
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public override int Read()
Public Overrides Function Read As Integer
public:
virtual int Read() override

Return Value

[Missing <returns> documentation for "M:csmic.Interpreter.UTF8Buffer.Read"]

See Also

UTF8Buffer Class
csmic.Interpreter Namespace


UTF8Buffer Properties

CS-MIC - C Sharp Math Input Control
UTF8Buffer Properties

The UTF8Buffer type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Pos | (Inherited from Buffer.)

See Also

UTF8Buffer Class
csmic.Interpreter Namespace


csmic.Scripting Namespace

CS-MIC - C Sharp Math Input Control
csmic.Scripting Namespace

[Missing <summary> documentation for "N:csmic.Scripting"]

Types

All Types | Classes
Name | Description
Buffer |
Errors |
FatalError |
Parser |
Scanner |
Token |
UTF8Buffer |


Buffer Class

| Members | See Also
CS-MIC - C Sharp Math Input Control
Buffer Class

[Missing <summary> documentation for "T:csmic.Scripting.Buffer"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public class Buffer
Public Class Buffer
public ref class Buffer

Members

All Members | Constructors | Fields | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Buffer(Buffer) | Initializes a new instance of the Buffer class
Buffer(Stream, Boolean) | Initializes a new instance of the Buffer class
Close()()()() |
EOF |
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | (Overrides Object..::..Finalize()()()().)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetString(Int32, Int32) |
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Peek()()()() |
Pos |
Read()()()() |
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
csmic.Scripting..::..Buffer
csmic.Scripting..::..UTF8Buffer

See Also

csmic.Scripting Namespace


Buffer Constructor

CS-MIC - C Sharp Math Input Control
Buffer Constructor

Overload List

Name | Description
Buffer(Buffer) | Initializes a new instance of the Buffer class
Buffer(Stream, Boolean) | Initializes a new instance of the Buffer class

See Also

Buffer Class
csmic.Scripting Namespace


Buffer Constructor (Buffer)

CS-MIC - C Sharp Math Input Control
Buffer Constructor (Buffer)
Initializes a new instance of the Buffer class

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
protected Buffer(
    Buffer b
)
Protected Sub New ( _
    b As Buffer _
)
protected:
Buffer(
    Buffer^ b
)

Parameters

b
Buffer

[Missing <param name="b"/> documentation for "M:csmic.Scripting.Buffer.#ctor(csmic.Scripting.Buffer)"]

See Also

Buffer Class
Buffer Overload
csmic.Scripting Namespace


Buffer Constructor (Stream, Boolean)

CS-MIC - C Sharp Math Input Control
Buffer Constructor (Stream, Boolean)
Initializes a new instance of the Buffer class

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public Buffer(
    Stream s,
    bool isUserStream
)
Public Sub New ( _
    s As Stream, _
    isUserStream As Boolean _
)
public:
Buffer(
    Stream^ s,
    bool isUserStream
)

Parameters

s
Stream

[Missing <param name="s"/> documentation for "M:csmic.Scripting.Buffer.#ctor(System.IO.Stream,System.Boolean)"]

isUserStream
Boolean

[Missing <param name="isUserStream"/> documentation for "M:csmic.Scripting.Buffer.#ctor(System.IO.Stream,System.Boolean)"]

See Also

Buffer Class
Buffer Overload
csmic.Scripting Namespace


Buffer Fields

CS-MIC - C Sharp Math Input Control
Buffer Fields

The Buffer type exposes the following fields.

Fields

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
EOF |

See Also

Buffer Class
csmic.Scripting Namespace


EOF Field

CS-MIC - C Sharp Math Input Control
Buffer..::EOF Field

[Missing <summary> documentation for "F:csmic.Scripting.Buffer.EOF"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public const int EOF
Public Const EOF As Integer
public:
literal int EOF

See Also

Buffer Class
csmic.Scripting Namespace


Buffer Methods

CS-MIC - C Sharp Math Input Control
Buffer Methods

The Buffer type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Close()()()() |
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | (Overrides Object..::..Finalize()()()().)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetString(Int32, Int32) |
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Peek()()()() |
Read()()()() |
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Buffer Class
csmic.Scripting Namespace


Close Method

CS-MIC - C Sharp Math Input Control
Buffer..::Close Method

[Missing <summary> documentation for "M:csmic.Scripting.Buffer.Close"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
protected void Close()
Protected Sub Close
protected:
void Close()

See Also

Buffer Class
csmic.Scripting Namespace


Finalize Method

CS-MIC - C Sharp Math Input Control
Buffer..::Finalize Method

[Missing <summary> documentation for "M:csmic.Scripting.Buffer.Finalize"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
protected override void Finalize()
Protected Overrides Sub Finalize
protected:
virtual void Finalize() override

See Also

Buffer Class
csmic.Scripting Namespace


GetString Method

CS-MIC - C Sharp Math Input Control
Buffer..::GetString Method

[Missing <summary> documentation for "M:csmic.Scripting.Buffer.GetString(System.Int32,System.Int32)"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public string GetString(
    int beg,
    int end
)
Public Function GetString ( _
    beg As Integer, _
    end As Integer _
) As String
public:
String^ GetString(
    int beg,
    int end
)

Parameters

beg
Int32

[Missing <param name="beg"/> documentation for "M:csmic.Scripting.Buffer.GetString(System.Int32,System.Int32)"]

end
Int32

[Missing <param name="end"/> documentation for "M:csmic.Scripting.Buffer.GetString(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:csmic.Scripting.Buffer.GetString(System.Int32,System.Int32)"]

See Also

Buffer Class
csmic.Scripting Namespace


Peek Method

CS-MIC - C Sharp Math Input Control
Buffer..::Peek Method

[Missing <summary> documentation for "M:csmic.Scripting.Buffer.Peek"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public int Peek()
Public Function Peek As Integer
public:
int Peek()

Return Value

[Missing <returns> documentation for "M:csmic.Scripting.Buffer.Peek"]

See Also

Buffer Class
csmic.Scripting Namespace


Read Method

CS-MIC - C Sharp Math Input Control
Buffer..::Read Method

[Missing <summary> documentation for "M:csmic.Scripting.Buffer.Read"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public virtual int Read()
Public Overridable Function Read As Integer
public:
virtual int Read()

Return Value

[Missing <returns> documentation for "M:csmic.Scripting.Buffer.Read"]

See Also

Buffer Class
csmic.Scripting Namespace


Buffer Properties

CS-MIC - C Sharp Math Input Control
Buffer Properties

The Buffer type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Pos |

See Also

Buffer Class
csmic.Scripting Namespace


Pos Property

CS-MIC - C Sharp Math Input Control
Buffer..::Pos Property

[Missing <summary> documentation for "P:csmic.Scripting.Buffer.Pos"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public int Pos { get; set; }
Public Property Pos As Integer
    Get
    Set
public:
property int Pos {
    int get ();
    void set (int value);
}

See Also

Buffer Class
csmic.Scripting Namespace


Errors Class

| Members | See Also
CS-MIC - C Sharp Math Input Control
Errors Class

[Missing <summary> documentation for "T:csmic.Scripting.Errors"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public class Errors
Public Class Errors
public ref class Errors

Members

All Members | Constructors | Fields | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Errors()()()() | Initializes a new instance of the Errors class
count |
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
errMsgFormat |
errorStream |
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
SemErr(String) |
SemErr(Int32, Int32, String) |
SynErr(Int32, Int32, Int32) |
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Warning(String) |
Warning(Int32, Int32, String) |

Inheritance Hierarchy

System..::..Object
csmic.Scripting..::..Errors

See Also

csmic.Scripting Namespace


Errors Constructor

CS-MIC - C Sharp Math Input Control
Errors Constructor
Initializes a new instance of the Errors class

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public Errors()
Public Sub New
public:
Errors()

See Also

Errors Class
csmic.Scripting Namespace


Errors Fields

CS-MIC - C Sharp Math Input Control
Errors Fields

The Errors type exposes the following fields.

Fields

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
count |
errMsgFormat |
errorStream |

See Also

Errors Class
csmic.Scripting Namespace


count Field

CS-MIC - C Sharp Math Input Control
Errors..::count Field

[Missing <summary> documentation for "F:csmic.Scripting.Errors.count"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public int count
Public count As Integer
public:
int count

See Also

Errors Class
csmic.Scripting Namespace


errMsgFormat Field

CS-MIC - C Sharp Math Input Control
Errors..::errMsgFormat Field

[Missing <summary> documentation for "F:csmic.Scripting.Errors.errMsgFormat"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public string errMsgFormat
Public errMsgFormat As String
public:
String^ errMsgFormat

See Also

Errors Class
csmic.Scripting Namespace


errorStream Field

CS-MIC - C Sharp Math Input Control
Errors..::errorStream Field

[Missing <summary> documentation for "F:csmic.Scripting.Errors.errorStream"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public TextWriter errorStream
Public errorStream As TextWriter
public:
TextWriter^ errorStream

See Also

Errors Class
csmic.Scripting Namespace


Errors Methods

CS-MIC - C Sharp Math Input Control
Errors Methods

The Errors type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
SemErr(String) |
SemErr(Int32, Int32, String) |
SynErr(Int32, Int32, Int32) |
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Warning(String) |
Warning(Int32, Int32, String) |

See Also

Errors Class
csmic.Scripting Namespace


SemErr Method

CS-MIC - C Sharp Math Input Control
Errors..::SemErr Method

Overload List

Name | Description
SemErr(String) |
SemErr(Int32, Int32, String) |

See Also

Errors Class
csmic.Scripting Namespace


SemErr Method (String)

CS-MIC - C Sharp Math Input Control
Errors..::SemErr Method (String)

[Missing <summary> documentation for "M:csmic.Scripting.Errors.SemErr(System.String)"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public void SemErr(
    string s
)
Public Sub SemErr ( _
    s As String _
)
public:
void SemErr(
    String^ s
)

Parameters

s
String

[Missing <param name="s"/> documentation for "M:csmic.Scripting.Errors.SemErr(System.String)"]

See Also

Errors Class
SemErr Overload
csmic.Scripting Namespace


SemErr Method (Int32, Int32, String)

CS-MIC - C Sharp Math Input Control
Errors..::SemErr Method (Int32, Int32, String)

[Missing <summary> documentation for "M:csmic.Scripting.Errors.SemErr(System.Int32,System.Int32,System.String)"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public void SemErr(
    int line,
    int col,
    string s
)
Public Sub SemErr ( _
    line As Integer, _
    col As Integer, _
    s As String _
)
public:
void SemErr(
    int line,
    int col,
    String^ s
)

Parameters

line
Int32

[Missing <param name="line"/> documentation for "M:csmic.Scripting.Errors.SemErr(System.Int32,System.Int32,System.String)"]

col
Int32

[Missing <param name="col"/> documentation for "M:csmic.Scripting.Errors.SemErr(System.Int32,System.Int32,System.String)"]

s
String

[Missing <param name="s"/> documentation for "M:csmic.Scripting.Errors.SemErr(System.Int32,System.Int32,System.String)"]

See Also

Errors Class
SemErr Overload
csmic.Scripting Namespace


SynErr Method

CS-MIC - C Sharp Math Input Control
Errors..::SynErr Method

[Missing <summary> documentation for "M:csmic.Scripting.Errors.SynErr(System.Int32,System.Int32,System.Int32)"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public void SynErr(
    int line,
    int col,
    int n
)
Public Sub SynErr ( _
    line As Integer, _
    col As Integer, _
    n As Integer _
)
public:
void SynErr(
    int line,
    int col,
    int n
)

Parameters

line
Int32

[Missing <param name="line"/> documentation for "M:csmic.Scripting.Errors.SynErr(System.Int32,System.Int32,System.Int32)"]

col
Int32

[Missing <param name="col"/> documentation for "M:csmic.Scripting.Errors.SynErr(System.Int32,System.Int32,System.Int32)"]

n
Int32

[Missing <param name="n"/> documentation for "M:csmic.Scripting.Errors.SynErr(System.Int32,System.Int32,System.Int32)"]

See Also

Errors Class
csmic.Scripting Namespace


Warning Method

CS-MIC - C Sharp Math Input Control
Errors..::Warning Method

Overload List

Name | Description
Warning(String) |
Warning(Int32, Int32, String) |

See Also

Errors Class
csmic.Scripting Namespace


Warning Method (String)

CS-MIC - C Sharp Math Input Control
Errors..::Warning Method (String)

[Missing <summary> documentation for "M:csmic.Scripting.Errors.Warning(System.String)"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public void Warning(
    string s
)
Public Sub Warning ( _
    s As String _
)
public:
void Warning(
    String^ s
)

Parameters

s
String

[Missing <param name="s"/> documentation for "M:csmic.Scripting.Errors.Warning(System.String)"]

See Also

Errors Class
Warning Overload
csmic.Scripting Namespace


Warning Method (Int32, Int32, String)

CS-MIC - C Sharp Math Input Control
Errors..::Warning Method (Int32, Int32, String)

[Missing <summary> documentation for "M:csmic.Scripting.Errors.Warning(System.Int32,System.Int32,System.String)"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public void Warning(
    int line,
    int col,
    string s
)
Public Sub Warning ( _
    line As Integer, _
    col As Integer, _
    s As String _
)
public:
void Warning(
    int line,
    int col,
    String^ s
)

Parameters

line
Int32

[Missing <param name="line"/> documentation for "M:csmic.Scripting.Errors.Warning(System.Int32,System.Int32,System.String)"]

col
Int32

[Missing <param name="col"/> documentation for "M:csmic.Scripting.Errors.Warning(System.Int32,System.Int32,System.String)"]

s
String

[Missing <param name="s"/> documentation for "M:csmic.Scripting.Errors.Warning(System.Int32,System.Int32,System.String)"]

See Also

Errors Class
Warning Overload
csmic.Scripting Namespace


FatalError Class

| Members | See Also
CS-MIC - C Sharp Math Input Control
FatalError Class

[Missing <summary> documentation for "T:csmic.Scripting.FatalError"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public class FatalError : Exception
Public Class FatalError _
    Inherits Exception
public ref class FatalError : public Exception

Members

All Members | Constructors | Properties | Methods | Events
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
FatalError(String) | Initializes a new instance of the FatalError class
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException()()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType()()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
ToString()()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Inheritance Hierarchy

System..::..Object
System..::..Exception
csmic.Scripting..::..FatalError

See Also

csmic.Scripting Namespace


FatalError Constructor

CS-MIC - C Sharp Math Input Control
FatalError Constructor
Initializes a new instance of the FatalError class

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public FatalError(
    string m
)
Public Sub New ( _
    m As String _
)
public:
FatalError(
    String^ m
)

Parameters

m
String

[Missing <param name="m"/> documentation for "M:csmic.Scripting.FatalError.#ctor(System.String)"]

See Also

FatalError Class
csmic.Scripting Namespace


FatalError Methods

CS-MIC - C Sharp Math Input Control
FatalError Methods

The FatalError type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException()()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType()()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString()()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

FatalError Class
csmic.Scripting Namespace


FatalError Properties

CS-MIC - C Sharp Math Input Control
FatalError Properties

The FatalError type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FatalError Class
csmic.Scripting Namespace


FatalError Events

CS-MIC - C Sharp Math Input Control
FatalError Events

The FatalError type exposes the following events.

Events

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

FatalError Class
csmic.Scripting Namespace


Parser Class

| Members | See Also
CS-MIC - C Sharp Math Input Control
Parser Class

[Missing <summary> documentation for "T:csmic.Scripting.Parser"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public class Parser
Public Class Parser
public ref class Parser

Members

All Members | Constructors | Fields | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Parser(Scanner) | Initializes a new instance of the Parser class
_binary |
_COMPARER |
_EOF |
_hex |
_identifier |
_LPAREN |
_newline |
_number |
_RPAREN |
_sign |
_string |
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
errors |
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
la |
maxT |
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Parse()()()() |
Root |
scanner |
SemErr(String) |
t |
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
csmic.Scripting..::..Parser

See Also

csmic.Scripting Namespace


Parser Constructor

CS-MIC - C Sharp Math Input Control
Parser Constructor
Initializes a new instance of the Parser class

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public Parser(
    Scanner scanner
)
Public Sub New ( _
    scanner As Scanner _
)
public:
Parser(
    Scanner^ scanner
)

Parameters

scanner
Scanner

[Missing <param name="scanner"/> documentation for "M:csmic.Scripting.Parser.#ctor(csmic.Scripting.Scanner)"]

See Also

Parser Class
csmic.Scripting Namespace


Parser Fields

CS-MIC - C Sharp Math Input Control
Parser Fields

The Parser type exposes the following fields.

Fields

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
_binary |
_COMPARER |
_EOF |
_hex |
_identifier |
_LPAREN |
_newline |
_number |
_RPAREN |
_sign |
_string |
errors |
la |
maxT |
scanner |
t |

See Also

Parser Class
csmic.Scripting Namespace


_binary Field

CS-MIC - C Sharp Math Input Control
Parser..::_binary Field

[Missing <summary> documentation for "F:csmic.Scripting.Parser._binary"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public const int _binary
Public Const _binary As Integer
public:
literal int _binary

See Also

Parser Class
csmic.Scripting Namespace


_COMPARER Field

CS-MIC - C Sharp Math Input Control
Parser..::_COMPARER Field

[Missing <summary> documentation for "F:csmic.Scripting.Parser._COMPARER"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public const int _COMPARER
Public Const _COMPARER As Integer
public:
literal int _COMPARER

See Also

Parser Class
csmic.Scripting Namespace


_EOF Field

CS-MIC - C Sharp Math Input Control
Parser..::_EOF Field

[Missing <summary> documentation for "F:csmic.Scripting.Parser._EOF"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public const int _EOF
Public Const _EOF As Integer
public:
literal int _EOF

See Also

Parser Class
csmic.Scripting Namespace


_hex Field

CS-MIC - C Sharp Math Input Control
Parser..::_hex Field

[Missing <summary> documentation for "F:csmic.Scripting.Parser._hex"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public const int _hex
Public Const _hex As Integer
public:
literal int _hex

See Also

Parser Class
csmic.Scripting Namespace


_identifier Field

CS-MIC - C Sharp Math Input Control
Parser..::_identifier Field

[Missing <summary> documentation for "F:csmic.Scripting.Parser._identifier"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public const int _identifier
Public Const _identifier As Integer
public:
literal int _identifier

See Also

Parser Class
csmic.Scripting Namespace


_LPAREN Field

CS-MIC - C Sharp Math Input Control
Parser..::_LPAREN Field

[Missing <summary> documentation for "F:csmic.Scripting.Parser._LPAREN"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public const int _LPAREN
Public Const _LPAREN As Integer
public:
literal int _LPAREN

See Also

Parser Class
csmic.Scripting Namespace


_newline Field

CS-MIC - C Sharp Math Input Control
Parser..::_newline Field

[Missing <summary> documentation for "F:csmic.Scripting.Parser._newline"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public const int _newline
Public Const _newline As Integer
public:
literal int _newline

See Also

Parser Class
csmic.Scripting Namespace


_number Field

CS-MIC - C Sharp Math Input Control
Parser..::_number Field

[Missing <summary> documentation for "F:csmic.Scripting.Parser._number"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public const int _number
Public Const _number As Integer
public:
literal int _number

See Also

Parser Class
csmic.Scripting Namespace


_RPAREN Field

CS-MIC - C Sharp Math Input Control
Parser..::_RPAREN Field

[Missing <summary> documentation for "F:csmic.Scripting.Parser._RPAREN"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public const int _RPAREN
Public Const _RPAREN As Integer
public:
literal int _RPAREN

See Also

Parser Class
csmic.Scripting Namespace


_sign Field

CS-MIC - C Sharp Math Input Control
Parser..::_sign Field

[Missing <summary> documentation for "F:csmic.Scripting.Parser._sign"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public const int _sign
Public Const _sign As Integer
public:
literal int _sign

See Also

Parser Class
csmic.Scripting Namespace


_string Field

CS-MIC - C Sharp Math Input Control
Parser..::_string Field

[Missing <summary> documentation for "F:csmic.Scripting.Parser._string"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public const int _string
Public Const _string As Integer
public:
literal int _string

See Also

Parser Class
csmic.Scripting Namespace


errors Field

CS-MIC - C Sharp Math Input Control
Parser..::errors Field

[Missing <summary> documentation for "F:csmic.Scripting.Parser.errors"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public Errors errors
Public errors As Errors
public:
Errors^ errors

See Also

Parser Class
csmic.Scripting Namespace


la Field

CS-MIC - C Sharp Math Input Control
Parser..::la Field

[Missing <summary> documentation for "F:csmic.Scripting.Parser.la"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public Token la
Public la As Token
public:
Token^ la

See Also

Parser Class
csmic.Scripting Namespace


maxT Field

CS-MIC - C Sharp Math Input Control
Parser..::maxT Field

[Missing <summary> documentation for "F:csmic.Scripting.Parser.maxT"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public const int maxT
Public Const maxT As Integer
public:
literal int maxT

See Also

Parser Class
csmic.Scripting Namespace


scanner Field

CS-MIC - C Sharp Math Input Control
Parser..::scanner Field

[Missing <summary> documentation for "F:csmic.Scripting.Parser.scanner"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public Scanner scanner
Public scanner As Scanner
public:
Scanner^ scanner

See Also

Parser Class
csmic.Scripting Namespace


t Field

CS-MIC - C Sharp Math Input Control
Parser..::t Field

[Missing <summary> documentation for "F:csmic.Scripting.Parser.t"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public Token t
Public t As Token
public:
Token^ t

See Also

Parser Class
csmic.Scripting Namespace


Parser Methods

CS-MIC - C Sharp Math Input Control
Parser Methods

The Parser type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Parse()()()() |
SemErr(String) |
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Parser Class
csmic.Scripting Namespace


Parse Method

CS-MIC - C Sharp Math Input Control
Parser..::Parse Method

[Missing <summary> documentation for "M:csmic.Scripting.Parser.Parse"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public void Parse()
Public Sub Parse
public:
void Parse()

See Also

Parser Class
csmic.Scripting Namespace


SemErr Method

CS-MIC - C Sharp Math Input Control
Parser..::SemErr Method

[Missing <summary> documentation for "M:csmic.Scripting.Parser.SemErr(System.String)"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public void SemErr(
    string msg
)
Public Sub SemErr ( _
    msg As String _
)
public:
void SemErr(
    String^ msg
)

Parameters

msg
String

[Missing <param name="msg"/> documentation for "M:csmic.Scripting.Parser.SemErr(System.String)"]

See Also

Parser Class
csmic.Scripting Namespace


Parser Properties

CS-MIC - C Sharp Math Input Control
Parser Properties

The Parser type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Root |

See Also

Parser Class
csmic.Scripting Namespace


Root Property

CS-MIC - C Sharp Math Input Control
Parser..::Root Property

[Missing <summary> documentation for "P:csmic.Scripting.Parser.Root"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
internal MacroOperation Root { get; set; }
Friend Property Root As MacroOperation
    Get
    Set
internal:
property MacroOperation^ Root {
    MacroOperation^ get ();
    void set (MacroOperation^ value);
}

See Also

Parser Class
csmic.Scripting Namespace


Scanner Class

| Members | See Also
CS-MIC - C Sharp Math Input Control
Scanner Class

[Missing <summary> documentation for "T:csmic.Scripting.Scanner"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public class Scanner
Public Class Scanner
public ref class Scanner

Members

All Members | Constructors | Fields | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Scanner(Stream) | Initializes a new instance of the Scanner class
Scanner(String) | Initializes a new instance of the Scanner class
buffer |
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Peek()()()() |
ResetPeek()()()() |
Scan()()()() |
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
csmic.Scripting..::..Scanner

See Also

csmic.Scripting Namespace


Scanner Constructor

CS-MIC - C Sharp Math Input Control
Scanner Constructor

Overload List

Name | Description
Scanner(Stream) | Initializes a new instance of the Scanner class
Scanner(String) | Initializes a new instance of the Scanner class

See Also

Scanner Class
csmic.Scripting Namespace


Scanner Constructor (Stream)

CS-MIC - C Sharp Math Input Control
Scanner Constructor (Stream)
Initializes a new instance of the Scanner class

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public Scanner(
    Stream s
)
Public Sub New ( _
    s As Stream _
)
public:
Scanner(
    Stream^ s
)

Parameters

s
Stream

[Missing <param name="s"/> documentation for "M:csmic.Scripting.Scanner.#ctor(System.IO.Stream)"]

See Also

Scanner Class
Scanner Overload
csmic.Scripting Namespace


Scanner Constructor (String)

CS-MIC - C Sharp Math Input Control
Scanner Constructor (String)
Initializes a new instance of the Scanner class

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public Scanner(
    string fileName
)
Public Sub New ( _
    fileName As String _
)
public:
Scanner(
    String^ fileName
)

Parameters

fileName
String

[Missing <param name="fileName"/> documentation for "M:csmic.Scripting.Scanner.#ctor(System.String)"]

See Also

Scanner Class
Scanner Overload
csmic.Scripting Namespace


Scanner Fields

CS-MIC - C Sharp Math Input Control
Scanner Fields

The Scanner type exposes the following fields.

Fields

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
buffer |

See Also

Scanner Class
csmic.Scripting Namespace


buffer Field

CS-MIC - C Sharp Math Input Control
Scanner..::buffer Field

[Missing <summary> documentation for "F:csmic.Scripting.Scanner.buffer"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public Buffer buffer
Public buffer As Buffer
public:
Buffer^ buffer

See Also

Scanner Class
csmic.Scripting Namespace


Scanner Methods

CS-MIC - C Sharp Math Input Control
Scanner Methods

The Scanner type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Peek()()()() |
ResetPeek()()()() |
Scan()()()() |
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Scanner Class
csmic.Scripting Namespace


Peek Method

CS-MIC - C Sharp Math Input Control
Scanner..::Peek Method

[Missing <summary> documentation for "M:csmic.Scripting.Scanner.Peek"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public Token Peek()
Public Function Peek As Token
public:
Token^ Peek()

Return Value

[Missing <returns> documentation for "M:csmic.Scripting.Scanner.Peek"]

See Also

Scanner Class
csmic.Scripting Namespace


ResetPeek Method

CS-MIC - C Sharp Math Input Control
Scanner..::ResetPeek Method

[Missing <summary> documentation for "M:csmic.Scripting.Scanner.ResetPeek"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public void ResetPeek()
Public Sub ResetPeek
public:
void ResetPeek()

See Also

Scanner Class
csmic.Scripting Namespace


Scan Method

CS-MIC - C Sharp Math Input Control
Scanner..::Scan Method

[Missing <summary> documentation for "M:csmic.Scripting.Scanner.Scan"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public Token Scan()
Public Function Scan As Token
public:
Token^ Scan()

Return Value

[Missing <returns> documentation for "M:csmic.Scripting.Scanner.Scan"]

See Also

Scanner Class
csmic.Scripting Namespace


Token Class

| Members | See Also
CS-MIC - C Sharp Math Input Control
Token Class

[Missing <summary> documentation for "T:csmic.Scripting.Token"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public class Token
Public Class Token
public ref class Token

Members

All Members | Constructors | Fields | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Token()()()() | Initializes a new instance of the Token class
charPos |
col |
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
kind |
line |
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
next |
pos |
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
val |

Inheritance Hierarchy

System..::..Object
csmic.Scripting..::..Token

See Also

csmic.Scripting Namespace


Token Constructor

CS-MIC - C Sharp Math Input Control
Token Constructor
Initializes a new instance of the Token class

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public Token()
Public Sub New
public:
Token()

See Also

Token Class
csmic.Scripting Namespace


Token Fields

CS-MIC - C Sharp Math Input Control
Token Fields

The Token type exposes the following fields.

Fields

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
charPos |
col |
kind |
line |
next |
pos |
val |

See Also

Token Class
csmic.Scripting Namespace


charPos Field

CS-MIC - C Sharp Math Input Control
Token..::charPos Field

[Missing <summary> documentation for "F:csmic.Scripting.Token.charPos"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public int charPos
Public charPos As Integer
public:
int charPos

See Also

Token Class
csmic.Scripting Namespace


col Field

CS-MIC - C Sharp Math Input Control
Token..::col Field

[Missing <summary> documentation for "F:csmic.Scripting.Token.col"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public int col
Public col As Integer
public:
int col

See Also

Token Class
csmic.Scripting Namespace


kind Field

CS-MIC - C Sharp Math Input Control
Token..::kind Field

[Missing <summary> documentation for "F:csmic.Scripting.Token.kind"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public int kind
Public kind As Integer
public:
int kind

See Also

Token Class
csmic.Scripting Namespace


line Field

CS-MIC - C Sharp Math Input Control
Token..::line Field

[Missing <summary> documentation for "F:csmic.Scripting.Token.line"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public int line
Public line As Integer
public:
int line

See Also

Token Class
csmic.Scripting Namespace


next Field

CS-MIC - C Sharp Math Input Control
Token..::next Field

[Missing <summary> documentation for "F:csmic.Scripting.Token.next"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public Token next
Public next As Token
public:
Token^ next

See Also

Token Class
csmic.Scripting Namespace


pos Field

CS-MIC - C Sharp Math Input Control
Token..::pos Field

[Missing <summary> documentation for "F:csmic.Scripting.Token.pos"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public int pos
Public pos As Integer
public:
int pos

See Also

Token Class
csmic.Scripting Namespace


val Field

CS-MIC - C Sharp Math Input Control
Token..::val Field

[Missing <summary> documentation for "F:csmic.Scripting.Token.val"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public string val
Public val As String
public:
String^ val

See Also

Token Class
csmic.Scripting Namespace


Token Methods

CS-MIC - C Sharp Math Input Control
Token Methods

The Token type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Token Class
csmic.Scripting Namespace


UTF8Buffer Class

| Members | See Also
CS-MIC - C Sharp Math Input Control
UTF8Buffer Class

[Missing <summary> documentation for "T:csmic.Scripting.UTF8Buffer"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public class UTF8Buffer : Buffer
Public Class UTF8Buffer _
    Inherits Buffer
public ref class UTF8Buffer : public Buffer

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
UTF8Buffer(Buffer) | Initializes a new instance of the UTF8Buffer class
Close()()()() | (Inherited from Buffer.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | (Inherited from Buffer.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetString(Int32, Int32) | (Inherited from Buffer.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Peek()()()() | (Inherited from Buffer.)
Pos | (Inherited from Buffer.)
Read()()()() | (Overrides Buffer..::..Read()()()().)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
csmic.Scripting..::..Buffer
csmic.Scripting..::..UTF8Buffer

See Also

csmic.Scripting Namespace


UTF8Buffer Constructor

CS-MIC - C Sharp Math Input Control
UTF8Buffer Constructor
Initializes a new instance of the UTF8Buffer class

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public UTF8Buffer(
    Buffer b
)
Public Sub New ( _
    b As Buffer _
)
public:
UTF8Buffer(
    Buffer^ b
)

Parameters

b
Buffer

[Missing <param name="b"/> documentation for "M:csmic.Scripting.UTF8Buffer.#ctor(csmic.Scripting.Buffer)"]

See Also

UTF8Buffer Class
csmic.Scripting Namespace


UTF8Buffer Methods

CS-MIC - C Sharp Math Input Control
UTF8Buffer Methods

The UTF8Buffer type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Close()()()() | (Inherited from Buffer.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize()()()() | (Inherited from Buffer.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetString(Int32, Int32) | (Inherited from Buffer.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Peek()()()() | (Inherited from Buffer.)
Read()()()() | (Overrides Buffer..::..Read()()()().)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UTF8Buffer Class
csmic.Scripting Namespace


Read Method

CS-MIC - C Sharp Math Input Control
UTF8Buffer..::Read Method

[Missing <summary> documentation for "M:csmic.Scripting.UTF8Buffer.Read"]

Namespace: csmic.Scripting
Assembly: csmic (in csmic.dll) Version: 1.1.3.0 (1.1.3.0)

Syntax

C# | Visual Basic | Visual C++
public override int Read()
Public Overrides Function Read As Integer
public:
virtual int Read() override

Return Value

[Missing <returns> documentation for "M:csmic.Scripting.UTF8Buffer.Read"]

See Also

UTF8Buffer Class
csmic.Scripting Namespace


UTF8Buffer Properties

CS-MIC - C Sharp Math Input Control
UTF8Buffer Properties

The UTF8Buffer type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Pos | (Inherited from Buffer.)

See Also

UTF8Buffer Class
csmic.Scripting Namespace